Closing sidebar doesn't redraw/reflow screen correctly.

VERIFIED FIXED

Status

P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: wrffr, Assigned: slamm)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
1.  Remove .mozilla directory and run ./mozilla-apprunner.
2.  Finish creating the profile.
3.  When the initial page of www.mozilla.org loads, select "View->Sidebar" to
remove the sidebar from the display.

At this point, the sidebar disappears correctly, but the contents of the window
are only shifted over to the left leaving an ugly blank area rather than
reflowing the current page to adjust for the new increase in width.

Comment 1

19 years ago
I can't reproduce this, can you tell me what build you are using? When I close
the sidebar via View | Sidebar, the page reflows correctly on my Linux machine.

I am using a build from 100108
(Reporter)

Comment 2

19 years ago
This is on RedHat 6.0.  The Build ID displayed in the corner of the Mozilla
window is 1999082316 and I'd performed a cvs update and rebuilt the entire src
tree earlier that day.
(Reporter)

Comment 3

19 years ago
Actually, to clarify a little more, I'd performed a cvs update on 10/8/99 and
rebuilt my tree using that.

Comment 4

19 years ago
I will leave this up to slamm, can't reproduce using 10/11 build.
(Reporter)

Comment 5

19 years ago
I did another cvs update and clobber build and am still having it occur, but not
every time, just most.  It's most visible when I open the browser window very
large (1500x1100 or more) before closing the sidebar.

What I'm seeing is when I select View->Sidebar--

1.  The contents of the sidebar panel between "My Panels" and "Alerts"
disappears, but the blue "My Panels" bar and the "Alerts" bar and below remain
in place.
2.  The main window reflows to adjust for the increase in size once the sidebar
will be gone ending up cutting off part of the right edge of the page.
3.  The rest of the sidebar disappears.
4.  The contents of the web page are shifted over to the left, leaving a blank
grey background area to the right.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

19 years ago
I do not see this bug anymore. There is a new one that the sidebar's iframe does
not disappear, but we have another bug for that.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 7

19 years ago
jdm, please re-open if you still see this
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.