Closed Bug 1596966 Opened 3 months ago Closed 3 months ago

Set `min-height: 0;` on <stack> children

Categories

(Toolkit :: Themes, task)

task
Not set

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox72 --- fixed

People

(Reporter: ntim, Assigned: ntim)

References

Details

Attachments

(1 file)

There's a couple of reasons to do this:

  • There are a couple of bugs (bug 1596725, bug 1596947, preferences main stack) that were caused by the min-height: auto behavior on the grid items which takes in account the implicit height of the content inside it. This caused some boxes to not be restrained by height of their parent.
  • The default min-height: auto for grid items is more expensive than min-height: 0 to compute since it takes in account many factors. This may be a way to address the TART regressions being seen in bug 1596416.
  • XUL <stack> was designed in a way where the dimensions are usually already decided by the parent element or the element itself, whereas CSS grid is more designed in a way where content decides the height, so min-height: 0 might make more sense here.
Component: Layout → Themes
Product: Core → Toolkit
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/1d6c106c86d5
Set `min-height: 0` on <stack> children. r=dholbert
Blocks: 1596416
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
Assignee: nobody → ntim.bugs
You need to log in before you can comment on or make changes to this bug.