Closed Bug 1596980 Opened 2 months ago Closed 2 months ago

Copy browser.experiments.urlbar.engagementTelemetry from top sites experiment to our mozilla-central experiment files

Categories

(Firefox :: Address Bar, task, P2)

task
Points:
2

Tracking

()

RESOLVED FIXED
Firefox 72
Iteration:
72.3 - Nov 18 - Dec 1
Tracking Status
firefox72 --- fixed

People

(Reporter: adw, Assigned: adw)

Details

Attachments

(1 file)

I tested the safe-mode problem we saw with the top sites experiment with the new nudges experiment, and it still happens. I know Shane was working on some bugs that addressed pref problems, so I wasn't sure whether it had been fixed, but it doesn't appear so (bug 1578513, bug 1586543, bug 1578508).

So we'll need to reuse Marco's browser.experiments.urlbar.engagementTelemetry browser setting API from top sites in our two new experiments. We should copy it over to our new little mini repo in mozilla-central.

This isn't a hard blocker for the experiments since we can always just copy it directly to the experiment repos, but it would be nice to do sooner rather than later.

It would also be nice to have a test, so I'll give this 2 points instead of 1.

Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/262d5c44d7a7
Copy browser.experiments.urlbar.engagementTelemetry from top sites experiment to our mozilla-central experiment files r=mak,mixedpuppy

This is in the log:

[task 2019-11-19T22:09:37.278Z] 22:09:37 INFO - GECKO(3542) | JavaScript error: , line 0: Error: Type error for details value (Property "levelOfControl" is required) for types.Setting.get.

I can't reproduce this locally. I notice that the error only happened on debug builds, so I wonder whether this is some check specific to debug builds. I don't see anything obvious in the code.

We're creating our own fake types.Setting API with this patch, so that seems related. Is there some levelOfControl property we're missing?

Flags: needinfo?(adw)

Yeah, there's an extra check on debug: https://searchfox.org/mozilla-central/rev/652014ca1183c56bc5f04daf01af180d4e50a91c/toolkit/components/extensions/Schemas.jsm#2685

I can reproduce this locally on a debug build. Not sure what to do about it though.

Oh, we just need to include a levelOfControl property in the object returned from get.

Pushed by rmaries@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/103fd2f2c4f3
Copy browser.experiments.urlbar.engagementTelemetry from top sites experiment to our mozilla-central experiment files r=mak,mixedpuppy
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72

Razvan, I think you landed this on m-c by accident. It landed on autoland earlier but got backed out due to a failing test. The m-c commit in comment 8 does not have the test fix, so I expect it will fail on m-c. Could you back it out of m-c, please?

Flags: needinfo?(rmaries)
Status: RESOLVED → REOPENED
Flags: needinfo?(rmaries)
Resolution: FIXED → ---
Target Milestone: Firefox 72 → ---
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/095697ce7a2e
Copy browser.experiments.urlbar.engagementTelemetry from top sites experiment to our mozilla-central experiment files r=mak,mixedpuppy
Status: REOPENED → RESOLVED
Closed: 2 months ago2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
You need to log in before you can comment on or make changes to this bug.