Closed Bug 1597068 Opened 11 months ago Closed 11 months ago

macOS sheets are no longer anchored to the #navigator-toolbox

Categories

(Firefox :: General, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 72
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- unaffected
firefox72 + verified

People

(Reporter: ntim, Assigned: bdahl)

References

(Regression)

Details

(Keywords: regression)

Attachments

(4 files)

Attached image After

I think that's the fault of the height: 0 in there. The element needs to have a non-empty rect.

The height was changed from 1px to 0 in https://hg.mozilla.org/mozilla-central/rev/cd43140ba52879d74162066e1531e36ac32df1b8 .

If you have suggestions for a better API, I'd love to hear them. This really doesn't have to be done with -moz-appearance. I bet we can find nicer ways to expose the sheet attachment position to the widget. For example, we could have a special attribute on the toolbox or on an element that defines the "content area". Or we could have an attribute on the root element which contains the ID of the toolbox or of the content area element.

(In reply to Markus Stange [:mstange] from comment #3)

The height was changed from 1px to 0 in https://hg.mozilla.org/mozilla-central/rev/cd43140ba52879d74162066e1531e36ac32df1b8 .

Thanks for looking into it!

(In reply to Markus Stange [:mstange] from comment #4)

For example, we could have a special attribute on the toolbox or on an element that defines the "content area". Or we could have an attribute on the root element which contains the ID of the toolbox or of the content area element.

Either of these suggestions sound good to me.

Moving to backlog as p3 to get it out of the triage list. Please adjust as necessary

Priority: -- → P3

[Tracking Requested - why for this release]: Bad regression that needs to be addressed in this release.

Priority: P3 → P1
Flags: needinfo?(bdahl)

I'm not exactly sure what changed, but the changes from bug 149582 are no
longer needed to fix test_queryCaretRect.htm and the position of the
drop down dialog.

Assignee: nobody → bdahl
Flags: needinfo?(bdahl)
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/fd4631c7d8cb
Revert navigator toolbox sheet anchor changes. r=dao
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
Flags: qe-verify+

In an attempt to reproduce(for verification), the issue did not appear to reproduce with 72.0a1(2019-11-16) on macOS 10.15.
Any additional details for this?

Flags: needinfo?(bdahl)

I'm unsure why this didn't reproduce, but there haven't been any more reports of issues. I'll clear needinfo for now.

Flags: needinfo?(bdahl)

Dropping the qe+ flag, since we cannot reproduce the bug.
Fwiw, the issue did not appear during our recurring test sessions on our macOS devices either so the patch appears to be working.

Flags: qe-verify+

@Tim; any chance you could chime in, if the patch has fixed the issue with the current version(s) for you?

Flags: needinfo?(ntim.bugs)
Attached image Fixed in Nightly

Seems fixed in Nightly for me.

Flags: needinfo?(ntim.bugs)

(It's supposed to look like the "Before" screenshot, and the wrong result is the "After" screenshot)

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.