Closed Bug 1597073 Opened 3 months ago Closed 3 months ago

Port |Bug 231654 - make delete normally only apply to the threadpane - too easy to accidentally delete folder|

Categories

(SeaMonkey :: MailNews: Message Display, enhancement)

enhancement
Not set

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53 affected, seamonkey2.57esr fixed)

RESOLVED FIXED
seamonkey2.69
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 --- affected
seamonkey2.57esr --- fixed

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

Details

Attachments

(1 file)

Port parts of Bug 231654:

  • Add helper function CanDeleteFolder() and make use of it.
  • Allow users to control behaviour of delete key (and Edit -> Delete) when folder pane has focus via a new preference.
Depends on: 1597062

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: None
Testing completed (on m-c, etc.): 2.53
Risk to taking this patch (and alternatives if risky): None
String changes made by this patch: None

Attachment #9109253 - Flags: review?(frgrahl)
Attachment #9109253 - Flags: approval-comm-release?
Attachment #9109253 - Flags: approval-comm-esr60?
Comment on attachment 9109253 [details] [diff] [review]
Folder delete patch

LGTM
Attachment #9109253 - Flags: review?(frgrahl)
Attachment #9109253 - Flags: review+
Attachment #9109253 - Flags: approval-comm-release?
Attachment #9109253 - Flags: approval-comm-release+
Attachment #9109253 - Flags: approval-comm-esr60?
Attachment #9109253 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/6d66ffc08e3f
Port |Bug 231654 - make delete normally only apply to the threadpane - too easy to accidentally delete folder|. r=frg

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.