Closed Bug 1597077 Opened 2 months ago Closed 2 months ago

Fix padding for tip results

Categories

(Firefox :: Address Bar, defect, P1)

defect
Points:
2

Tracking

()

RESOLVED FIXED
Firefox 72
Iteration:
72.3 - Nov 18 - Dec 1
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- unaffected
firefox72 --- fixed

People

(Reporter: adw, Assigned: adw)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Tip results don't have their intended padding. Looks like bug 1593959 regressed this.

it would be nice to have a script to run in the Browser Console, or an add-on, registering a provider that returns one result per type, when testing theme/alignment changes. Getting Tip results is a problem because there's no integrated provider doing it, nor an add-on one can easily install for testing purposes.

Attached patch tip_test.diffSplinter Review

I've kept this patch floating around in my tree and rebase it on top of my work to test tip changes. I agree we should have something a bit easier to use though.

Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3556245dd362
Fix padding for tip results. r=harry

Is mozscreenshots still running? We could use that. Otherwise, in addition to the ideas mentioned here (an add-on, Harry's script), another manual testing possibility is to run one of the browser tests that creates a tip and stop it (e.g. add an await new Promise(r => {})) when it's shown.

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72

(In reply to Harry Twyford [:harry] from comment #3)

we should have something a bit easier to use

Here's an add-on! https://github.com/htwyford/urlbar-results-tester

You need to log in before you can comment on or make changes to this bug.