-turbo shouldn't steal focus

VERIFIED FIXED

Status

SeaMonkey
UI Design
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Gili, Assigned: mkaply)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

517 bytes, patch
jhp (no longer active)
: review+
jhp (no longer active)
: superreview+
Details | Diff | Splinter Review
57.57 KB, patch
jhp (no longer active)
: review+
jhp (no longer active)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.1b) Gecko/20020724
BuildID:    2002072408

Running Mozilla -turbo (seemingly) causes it to open up and minimize very
quickly to accomplish its goal.

You shouldn't be poping up anything at all. If I place "mozilla -turbo" in my
startup script it keeps on stealing the focus away from me while I'm typing in
some other window.

Mozilla -turbo should run completely transparent to the end-user and should not
involve any visible GUI components.

Reproducible: Didn't try
(Reporter)

Comment 1

16 years ago
Correction to title :) changed "should steal focus" to "shouldn't steal focus"
Summary: -turbo should steal focus → -turbo shouldn't steal focus
(Assignee)

Comment 2

16 years ago
Taking
Assignee: sgehani → mkaply
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

16 years ago
Created attachment 93454 [details] [diff] [review]
Part 1 of fix

There are really two problems here.

Problem 1 is that the window comes up at all.

Problem 2 is the focus.

This first patch is the focus issue.

The second patch will be a rewrite of nsNativeAppSupportOS2.cpp to bring our
turbo up to Windows and hence fix the rest of the problems.
(Assignee)

Comment 4

16 years ago
Created attachment 93455 [details] [diff] [review]
Report of nsNativeAppSupportOS2

Every so often we have to report nsNativeAppSupport to get the latest stuff
from windows, especially for turbo mode and DDE.

That's what this is.

This fixes some misc traps with turbo mode, as well as some DDE functions that
weren't working.

It's also some general cleanup of the file to be more like Windows.
Comment on attachment 93454 [details] [diff] [review]
Part 1 of fix

r=pedemont,
sr=blizzard (platform specific code)
Attachment #93454 - Flags: superreview+
Attachment #93454 - Flags: review+
Comment on attachment 93455 [details] [diff] [review]
Report of nsNativeAppSupportOS2

if you set MOZ_DEBUG_DDE to 0 instead of one, then:
r=pedemont,
sr=blizzard (platform specific code)
Attachment #93455 - Flags: superreview+
Attachment #93455 - Flags: review+
(Assignee)

Comment 7

16 years ago
Fixes checked in.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

16 years ago
verified this is fixed.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.