Closed Bug 1597316 Opened 22 days ago Closed 21 days ago

Scroll is not prevented and keyup is required when navigating login list with keys

Categories

(Firefox :: about:logins, defect, P2)

defect

Tracking

()

VERIFIED FIXED
Firefox 72
Tracking Status
firefox72 --- verified

People

(Reporter: mstriemer, Assigned: mstriemer)

Details

Attachments

(1 file)

When navigating the login list with the up/down arrow keys, the list still scrolls. You can see the difference when using the left/right keys which also changes the selection but does not cause the same scrolling effect.

You are also required to let the key back up to navigate to the next item, rather than being able to hold the key down to keep moving the selection.

This looks like it was probably regressed by bug 1581014 which moved all the event handlers to keyup instead of just the space/enter one.

Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ad32f331d00a
Don't scroll login list on arrows, allow holding an arrow to navigate r=MattN
Pushed by rmaries@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/a3d6472ad3e9
Don't scroll login list on arrows, allow holding an arrow to navigate r=MattN
Status: NEW → RESOLVED
Closed: 21 days ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
Flags: qe-verify+

I have verified this issue and is no longer reproducible on the Firefox Beta 72.0b3 (Build ID: 20191205201734) on Windows 10 x64, Mac 10.14, Ubuntu 16.04 x64.

  • The Login List is not scrolled when navigating with the arrow keys.
  • All the logins from the list are focused when pressing and holding the arrow keys.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.