Form Manager doesn't save radio button element state information

RESOLVED WONTFIX

Status

()

Toolkit
Form Manager
RESOLVED WONTFIX
16 years ago
9 years ago

People

(Reporter: Bill Hobbs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.1b) Gecko/20020722
BuildID:    2002072203

I'm currently unemployed and visit several job boards for leads.  I thought I
would have Mozilla's form manager to fill in the search forms with the values
that I commonly use.  It appears that the forms manager does not store radio
button values at all.

Reproducible: Always
Steps to Reproduce:
1. tools -> form manager -> edit form info; click remove all saved data button
2. go to http://www.dice.com/jobsearch/
3. make entries - in my case: "vms or openvms or dcl or vax or ingres or rdb",
boolean, first four entries in state list, 7 days, 50 jobs, 2000 matches
4. tools -> form manager -> save form info; click ok button in alert
5. go to http://www.dice.com/jobsearch/
6. tools -> form manager -> fill in form

Actual Results:  The boolean radio button is not selected.

Expected Results:  It appears that radio buttons are not stored at all.  I think
that radio button values could be stored in the url specific category.

Split per http://bugzilla.mozilla.org/show_bug.cgi?id=159676#c2

I think I understand Morse's point of view at the above comment as storing
values that are common to many different web pages, like name, address, phone. 
I am trying to store values that are specific to one web page that I visit
repeatedly, there is no need or desire to share the values with other pages.

Comment 1

16 years ago
Confirmed using Mac/2002080208/9.2.2. The Form Manager doesn't save radio button 
element state information.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: radio button form info not saved at all → Form Manager doesn't save radio button element state information

Updated

16 years ago
Target Milestone: --- → Future
dveditz is the new module owner, reassigning.
Assignee: morse → dveditz

Comment 3

15 years ago
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".

Comment 4

14 years ago
Since Mozilla is no longer supported on Mac OS X pre-OS X I am attepting to test
the remaining open bugs (all 175 of them).

The test client will be the Mozilla (SeaMonkeys) 1.6 running Mac OS X 10.3.2

Result/Status: Valid bug, all OS's?

Updated

14 years ago
OS: Mac System 9.x → All
Hardware: Macintosh → All
Assignee: dveditz → nobody
The current implementation, satchel, does not and won't save radio button values.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
QA Contact: tpreston → form-manager
Resolution: --- → WONTFIX
Component: Form Manager → Form Manager
Product: Core → Toolkit
QA Contact: form-manager → form.manager
Target Milestone: Future → ---
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.