Closed Bug 1597405 Opened 2 months ago Closed 8 days ago

Fix uses of nsDocShellLoadState::SetupInheritingPrincipal in docshell/base/nsDocShellLoadState.cpp

Categories

(Core :: DOM: Navigation, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1596820
Fission Milestone M6

People

(Reporter: djvj, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [rm-docshell-tree-item:simple])

In file docshell/base/nsDocShellLoadState.cpp

Trivial use of ItemType for nsIDocShellTreeItem

Change to use BrowsingContext::Type

Needs change to users.

Kannan says replacing nsIDocShellTreeItem calls should block enabling Fission in Nightly (M6).

Fission Milestone: --- → M6
Priority: -- → P3

Yeah this is a dup, must have gotten double-counted.

Status: NEW → RESOLVED
Closed: 8 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1596820
You need to log in before you can comment on or make changes to this bug.