Closed Bug 1597426 Opened 2 years ago Closed 2 years ago

Fix uses of nsFrameLoader::StartDestroy in dom/base/nsFrameLoader.cpp

Categories

(Core :: DOM: Navigation, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1597512
Fission Milestone M6

People

(Reporter: djvj, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [rm-docshell-tree-item:simple])

In file dom/base/nsFrameLoader.cpp

Uses DocShell tree to get parent item, gets owner of parent item, and removes tree-item from it.

This will change to some sort of de-registration from the BrowsingContextGroup, or get removed and the de-registration done elsewhere.

TabContext may need to acquire a “mPrimaryContentShell” to mirror nsDocShellTreeOwner’s field.

Kannan says replacing nsIDocShellTreeItem calls should block enabling Fission in Nightly (M6).

Fission Milestone: --- → M6
Priority: -- → P3
Assignee: nobody → dteller

I don't quite understand what's needed here. There's only one use of StartDestroy and it's in Destroy, so I assume that I'm misunderstanding what this bug is about.

Flags: needinfo?(kvijayan)

In the absence of info, dropping bug.

Assignee: dteller → nobody

This field is related to the mPrimaryContentShell field, which may be possible to remove. Marking as a duplicate of bug 1597512

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(kvijayan)
Resolution: --- → DUPLICATE
Duplicate of bug: 1597512
You need to log in before you can comment on or make changes to this bug.