everything is inherited into the new boxes in a <marquee>

RESOLVED FIXED in mozilla1.7alpha

Status

()

Core
CSS Parsing and Computation
P3
normal
RESOLVED FIXED
16 years ago
14 years ago

People

(Reporter: Kai Lahmann (is there, where MNG is), Assigned: bz)

Tracking

({testcase})

Trunk
mozilla1.7alpha
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
..even properties, which shouldn't, as padding, background-image, border, margin
or width/height

Comment 2

16 years ago
I beleive it's because the way it's implemented...

Updated

16 years ago
Keywords: testcase

Updated

16 years ago
QA Contact: petersen → amar

Comment 3

16 years ago
I see the problem. Thats not the way its suppose to render. Confirming the bug 
and changing the component to style system
Status: UNCONFIRMED → NEW
Component: Layout → Style System
Ever confirmed: true
Priority: -- → P3
QA Contact: amar → madhur

Comment 4

16 years ago
testcase should show only one 100px height rectangular box with 1px solid lime 
border. But I see two 100px height rect boxes on branch builds: 
2002-08-01-08-1.0 on WIN2K. 
How about reassigning this too?  ;)

The problem is just that style is applied to the anonymous content inside the
<marquee>... Shouldn't XBL prevent that from happening?  I seem to recall there
being something in place for that...
Assignee: attinasi → dbaron
QA Contact: madhur → ian

Comment 6

16 years ago
Are you wanting to stop rules in author sheets from applying, or are you wanting to actually cut off CSS inheritance of properties like font and color?  XBL can do the former, but does not have any mechanism for the latter.
I think in this case preventing author rules from applying is what we need.

Comment 8

15 years ago
The URL is now a 404.
Comment on attachment 138821 [details] [diff] [review]
Equally simple fix

David, would you review?  I'll fix up the tab in the second hunk before
checking in.
Attachment #138821 - Flags: superreview?(dbaron)
Attachment #138821 - Flags: review?(dbaron)
Comment on attachment 138821 [details] [diff] [review]
Equally simple fix

Properties still inherit to the real content, right?  Just not the anonymous
content?  If so (test that 'color' still works, when inherited), r+sr=dbaron.
Attachment #138821 - Flags: superreview?(dbaron)
Attachment #138821 - Flags: superreview+
Attachment #138821 - Flags: review?(dbaron)
Attachment #138821 - Flags: review+
Yeah, that still works.  And document rules still apply to the real content.

"inheritstyle" is really pretty badly named...
Assignee: dbaron → bz-vacation
Target Milestone: --- → mozilla1.7alpha
Fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 15

14 years ago
Comment on attachment 138820 [details]
Simple testcase

Note that IE6/Win shows a top and bottom border on the marquee with this
testcase. Are we aiming for (marquee-)parity with IE?

Comment 16

14 years ago
The current XBL spec has a different name for "inheritstyle."  I agree that the name is bad, and Hixie and 
I have fixed it in the spec.
Malcolm, could you attach a screenshot of what IE shows?
Um... so the non-anonymous div in IE is _not_ being scrolled with the text?  Or
what?  Notice that in Mozilla, with my patch, there is a single red border
around the text; but it's shrink-wrapped.
The text is moving, just the left and right div borders are never visible.
Right.  So it scrolls the text, but it's not clear what it's doing with the div.
 I don't think we care, really.
You need to log in before you can comment on or make changes to this bug.