Mozilla crashes at news.com.com when back button selected

RESOLVED DUPLICATE of bug 152429

Status

--
critical
RESOLVED DUPLICATE of bug 152429
16 years ago
14 years ago

People

(Reporter: DomIncollingo, Assigned: samir_bugzilla)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020725
BuildID:    2002072508

Mozilla crashes at news.com.com when the back button is selected or when the
user clicks on a link on this page.

Reproducible: Always
Steps to Reproduce:
1.Launch Mozilla and display home page.
2.Navigate to news.com.com (Cnet news home page)
3.Click the back button to return to your home page.
4.Mozilla crashes.

Alternative steps to reproduce:

1.Launch Mozilla and display home page.
2.Navigate to news.com.com (Cnet news home page)
3.Click on one of the links on this page.
4.Mozilla crashes (usually, but not always).

Actual Results:  Mozilla crashes.

Expected Results:  Mozilla should not crash.

In the 'alternative steps to reproduce' (listed above), Mozilla crashes when a
link on the news.com.com page is clicked in an attempt to navigate to another
news article.  However, if you navigate directly to another news article by
entering the URL in the navigation field (rather than clicking on a link on the
news.com.com page), then Mozilla does not crash.

Comment 1

16 years ago
Dom, do you get a Talkback window popup when crashing ? If so, please post
Talkback ID for this crash by running 'mozilla/bin/components/talkback/talkback'.
Severity: major → critical
Keywords: crash, stackwanted

Comment 2

16 years ago
marking dupe  (crash with flash in an iframe).  this was recently fixed.
please reopen if you can reproduce in a newer nightly build.

*** This bug has been marked as a duplicate of 152429 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

16 years ago
Olivier, I haven't gotten Talkback to work since I switched from Windows to
Linux 3 weeks ago. I download the tar.gz file, extract its files, and run the
installer. But Talkback never activates. When Mozilla crashes, it just
disappears without creating a Talkback report.  Could you direct me to a site
that explains how to set up Talkback in a Linux environment?

Comment 4

16 years ago
You shouldn't need to do anything special to activate talkback.  In this
specific crash, talkback does not activate because gdk actually detects a
problem and calls exit.

You can configure talkback by running mozilla_dir/components/talkback/talkback,
but it should bring the configuration up the first time you crash.  you can test
talkback at bug 154797 (try out the testcase)
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.