Closed Bug 1597541 Opened 5 months ago Closed 4 months ago

Add a pref and disable nsContentBlocker by default

Categories

(Core :: Permission Manager, task, P1)

task

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
relnote-firefox --- 72+
firefox72 --- fixed

People

(Reporter: pbz, Assigned: pbz)

References

Details

(Keywords: dev-doc-needed)

Attachments

(1 file)

Before we remove nsContentBlocker in Bug 1357107 we should add a pref to disable it by default for Firefox 72. When nsContentBlocker is disabled we should also hide the image blocking checkbox in the PageInfo dialog.

Telemetry for FF 71 shows very low usage of content blocking permissions (< 1% of users):
https://mzl.la/33XGo5B

Priority: -- → P1
Pushed by pzuhlcke@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8698df283c0c
Added pref and disabled nsContentBlocker by default. r=Ehsan
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72

What kind of developer documentation does this need Tom?

Maybe developer documentation is not the right place, but this feels not quite important enough for release notes.

Hmm, maybe, let's see what the release management team thinks. Let's flag the bug for visibility for now. IMHO a release note is probably a better place to document this change...

Release Note Request (optional, but appreciated)
[Why is this notable]: We're removing support for blocking images from websites.
[Affects Firefox for Android]: Yes, even though there's no UI for this on Firefox for Android (feature was accessible through about:config).
[Suggested wording]: Support for blocking images from individual domains has been removed from Firefox, because of low usage and poor user experience. Content Blocker extensions like uMatrix are a much better alternative for addressing this use case.
[Links (documentation, blog post, etc)]: None.

relnote-firefox: --- → ?
Regressions: 1608004
Regressions: 1607985
You need to log in before you can comment on or make changes to this bug.