Closed Bug 1597939 Opened 3 months ago Closed 3 months ago

Attendees listed with white text on white background

Categories

(Calendar :: Dialogs, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
68.3.1

People

(Reporter: dag, Assigned: Paenglab)

References

Details

Attachments

(3 files)

Attached image attendee.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0

Steps to reproduce:

Create 'New Event'
Invite attendees
Click in the empty field below my own email address, start typing.
A dropdown list with matching addresses appears. Choose one.

Actual results:

The attendee is added, and a new attendee can be selected in the same way in the newly created field below the one we just populated.
The attendee we just added is 'invisible', as the mail address is white text on white background.
I can highlight the text in field, or individual pieces of the text. But when not highlighted, it is invisible.

Expected results:

Attendees should be shown with text-color visible on the background-color.

I have tried a number of combinations of gtk-themes, thunderbird themes, system-color overrides, variants of overrides +++. None appears to have the slightest impact on this particular UI element.

I managed to work around this particular annoyance by editing out my preference for dark themes in the gtk config file
(.config/gtk-3.0/settings.ini)

Like this:
[Settings]
;gtk-application-prefer-dark-theme=1

Can I have an affinity for dark themes and still see my attendees? Installed gtk themes are:
Adwaita
Adwaita Dark
HighContrast
Raleigh

To clarify previous comment:

I found a workaround while writing the previous comment. Lightning appears to honor 'gtk-application-prefer-dark-theme=1', but the UI element in question becomes invisible with it.

Paul, to test this you need to set a dark system theme. -moz-Field is on light themes normally white, so no change on light themes but it works now on dark system themes.

Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #9110254 - Flags: review?(paul)
Comment on attachment 9110254 [details] [diff] [review]
1597939-attendee-colours.patch

Review of attachment 9110254 [details] [diff] [review]:
-----------------------------------------------------------------

Tested with a dark system theme (thanks for the tip), and it looks good.  Fixes the issue.  Code changes look good.
Attachment #9110254 - Flags: review?(paul) → review+
Attachment #9110254 - Flags: approval-calendar-beta?(paul)

Patch for ESR.
Slightly different because the textbox de-XBL changes aren't in ESR.

Attachment #9110366 - Flags: approval-calendar-esr?(paul)
Attachment #9110254 - Flags: approval-calendar-esr+
Attachment #9110254 - Flags: approval-calendar-beta?(paul)
Attachment #9110254 - Flags: approval-calendar-beta+
Attachment #9110254 - Flags: approval-calendar-esr+
Attachment #9110366 - Flags: approval-calendar-esr?(paul) → approval-calendar-esr+

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/a0402b8ff64e
Fix some background colours in attendee dialog with dark system theme. r=pmorris

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 72
Target Milestone: 72 → 71
Component: Preferences → Dialogs
Target Milestone: 71 → 68.3.1
Regressions: 1604797
You need to log in before you can comment on or make changes to this bug.