[RFE] Clearing history and cache does not clear downloads and search

VERIFIED DUPLICATE of bug 11008

Status

SeaMonkey
UI Design
--
enhancement
VERIFIED DUPLICATE of bug 11008
16 years ago
14 years ago

People

(Reporter: lsof, Assigned: Samir Gehani)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020618
BuildID:    

When clearing history and cache, downloads.rdf and search.rdf are not also cleared.

Reproducible: Always
Steps to Reproduce:
1. Download or search for something
2. Clear history and cache
3. Restart mozilla
4. View downloads.rdf or search.rdf - not cleared

Actual Results:  downloads.rfs and search.rdf not cleared

Expected Results:  downloads.rfs and search.rdf cleared

Comment 1

16 years ago
1) "Clear Cache" button and "Clear History" button are supposed to do just what
they say, clear cache and histroy, appropriately. It would be a bug to make them
do something else.

2) To clear downloads, go to Download Manager, select all items and press "Remove"
(Well, I know this button might not work sometimes, but it's another bug and
we're working on it).

==> Duping to the bug that requests "Clear All" button.


*** This bug has been marked as a duplicate of 11008 ***
Severity: normal → enhancement
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Summary: Clearing history and cache does not clear downloads and search → [RFE] Clearing history and cache does not clear downloads and search
(Reporter)

Comment 2

16 years ago
History implies "whatever I have visited".

Comment 3

16 years ago
*** Bug 155298 has been marked as a duplicate of this bug. ***

Comment 4

14 years ago
V: dupe.
Status: RESOLVED → VERIFIED
QA Contact: pawyskoczka → benc
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.