Closed Bug 1597946 Opened 3 months ago Closed 3 months ago

Browser debugger goes blank

Categories

(DevTools :: Debugger, defect, P1)

defect

Tracking

(firefox72 fixed)

RESOLVED FIXED
Firefox 72
Tracking Status
firefox72 --- fixed

People

(Reporter: Honza, Assigned: jlast)

Details

Attachments

(1 file)

This happened to me today when debugging MQTT WS payload

STR:

  1. Download and apply this patch: https://phabricator.services.mozilla.com/D41445
  2. Build and Run Firefox
  3. Open DevTools & Network panel on http://rtsdp.eu5.org/dashboard/TestMosquittoOrgDashboard.html
  4. You should see WS 101 HTTP request in the list, select it and go to the Messages panel - Do not select any frame yet
  5. Open the Browser Debugger and create BP in netmonitor/src/components/websockets/FramePayload.js on line 159 (it should be where const decoder = MQTTDecoder(); ctor is called.
  6. Select a WS frame in the Messages panel
  7. The BP should hit. Hover over the MQTTDecoder(); ctor to see a preview -> the entire browser debugger panel goes blank

Honza

Jason, can you reproduce that?
Can you please investigate this ASAP?

Honza

Flags: needinfo?(jlaster)

Looking into it

Flags: needinfo?(jlaster)

Thanks for sharing.

This is failing because we're trying to create a rep with an empty array of roots. Rep({ object: result }) in Popup.js. The issue is that shouldRenderRootsInReps check crashes when doing this check.

One simple fix would be to change the roots length check at the top to if (roots.length !== 1).

Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8127325c6941
Browser debugger goes blank. r=nchevobbe
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
Assignee: nobody → jlaster
You need to log in before you can comment on or make changes to this bug.