Closed Bug 1597957 Opened 10 months ago Closed 10 months ago

Build bustage during configure due to bug 1596438

Categories

(Firefox Build System :: General, defect)

defect
Not set
critical

Tracking

(firefox-esr68 unaffected, firefox70 unaffected, firefox71 unaffected, firefox72+ fixed)

RESOLVED FIXED
mozilla72
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- unaffected
firefox72 + fixed

People

(Reporter: RyanVM, Assigned: rstewart)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 obsolete file)

Since bug 1596438 landed, I haven't been able to get through configure with the error shown below. I've tried clobbering and |hg purge --all|, but only a local backout was able to resolve the issue.

Reticulating splines...
Traceback (most recent call last):
  File "c:/Users/Ryan/repos/mozilla/configure.py", line 170, in <module>
    sys.exit(main(sys.argv))
  File "c:/Users/Ryan/repos/mozilla/configure.py", line 51, in main
    return config_status(config)
  File "c:/Users/Ryan/repos/mozilla/configure.py", line 165, in config_status
    return config_status(args=[], **normalize(sanitized_config))
  File "c:\Users\Ryan\repos\mozilla\python\mozbuild\mozbuild\config_status.py", line 142, in config_status
    definitions = list(definitions)
  File "c:\Users\Ryan\repos\mozilla\python\mozbuild\mozbuild\frontend\emitter.py", line 194, in emit
    objs = list(self._emit_libs_derived(contexts))
  File "c:\Users\Ryan\repos\mozilla\python\mozbuild\mozbuild\frontend\emitter.py", line 228, in _emit_libs_derived
    collection = cls(contexts[root])
KeyError: u'c:/Users/Ryan/repos/mozilla/objdir-clang/dom/bindings'
*** Fix above errors and then restart with\
               "./mach build"
mozmake.EXE: *** [client.mk;115: configure] Error 1
Flags: needinfo?(rstewart)
Attachment #9110280 - Attachment is obsolete: true

I've got a feeling a proper fix to this issue is going to take a substantial amount of time, so I just asked the sheriffs to back the original patch out, since it'll fix whatever your problem is and the original bug doesn't need to be dealt with urgently.

Flags: needinfo?(rstewart)
Assignee: nobody → rstewart
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
You need to log in before you can comment on or make changes to this bug.