wrong vertical positioning of context-menu set for a listbox-listitem inside vbox, lower part of screen

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
17 years ago
11 years ago

People

(Reporter: ajbu, Assigned: hyatt)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

5.50 KB, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

17 years ago
Tested on Mozilla 2002072408

When setting a context-menu to a listitem inside a listbox, and that listbox 
is inside a vbox in the lower part of the screen,  the context menu pops up at 
the wrong vertical position, in the upper half of the screen.
Somehow the position seems to relate to the top of the listbox, and the 
position of the window relative to the desktop.
When moving the Mozilla-application window, the menu pops-up at the same 
absolute (absolute to the desktop) position.
Could not reproduce this on Linxus, only on Windows (XP)
Testcase follows
(Reporter)

Comment 1

17 years ago
Created attachment 93090 [details]
XUL Test case of popup on listitem

To see the problem, make sure the listbox top is in the lower part of the
screen (near the bottom) en right-click on a listboxitem.  Popup shows up in
the wrong position.

Comment 2

17 years ago
Confirmed 2002072718
Status: UNCONFIRMED → NEW
Ever confirmed: true
Bug also occurs on Linux, 2002-07-27-21 (trunk).
OS: Windows XP → All
WFM, 2002-08-20-08 trunk Linux.

ajbu@planet.nl - could you try the latest build and see if it now works as you
expected (I'm not very good at XUL).
(Reporter)

Comment 5

17 years ago
No longer a problem in latest build.
Looks like this is fixed in the previous week.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
There are no patches here that was checked in so FIXED is not the
correct resolution. For bugs like this one where the problem was confirmed but
then later not reproducible any longer, resolve as WORKSFORME.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
WORKSFORME
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Updated

11 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.