Closed Bug 1598285 Opened 3 months ago Closed 3 months ago

Network Panel Search - Search never stop after a web page is refreshed

Categories

(DevTools :: Netmonitor, defect, P3)

72 Branch
defect

Tracking

(firefox71 verified, firefox72 verified)

VERIFIED FIXED
Firefox 72
Tracking Status
firefox71 --- verified
firefox72 --- verified

People

(Reporter: marcela.calderon, Assigned: duncangleeddean, Mentored)

References

(Blocks 2 open bugs)

Details

(Keywords: good-first-bug)

Attachments

(2 files)

After starting a search if a web page is refreshed searching never stoped

Affected versions
Firefox versions Nightly 72.0a1 , Beta 71.0b11

Affected platforms
Windows 10
macOS 10.14
Ubuntu 18.04

Steps to reproduce
Go to cnn.com
Open the network panel search
Start a search after "a" and during the search is performed refresh the web page

Expected Result
Search should be ended as usual

Actual Result
Search never stops. "Searching..." label stays always visible and working.

Note
If clicks on any result while "Searching" is working, no results are displayed on the left Side Panel

Good catch, thanks for the report!

I can reproduce this on my machine.

Honza

Has STR: --- → yes
Priority: -- → P3
Attached image image.png

Some instructions for anyone interested in fixing this bug

  1. See the attached screenshot it shows the related UI

  2. The search is an asynchronous operation and it's happening here:
    https://searchfox.org/mozilla-central/rev/652014ca1183c56bc5f04daf01af180d4e50a91c/devtools/client/netmonitor/src/actions/search.js#46

  3. The newOngoingSearch is stored in a reducer (using addOngoingSearch action) here:
    https://searchfox.org/mozilla-central/rev/652014ca1183c56bc5f04daf01af180d4e50a91c/devtools/client/netmonitor/src/reducers/search.js#32

  4. The search can be cancelled using stopOngoingSearch action
    https://searchfox.org/mozilla-central/rev/652014ca1183c56bc5f04daf01af180d4e50a91c/devtools/client/netmonitor/src/actions/search.js#250

  5. The stopOngoingSearch should be called when the page is reloaded somewhere in this function:
    https://searchfox.org/mozilla-central/rev/652014ca1183c56bc5f04daf01af180d4e50a91c/devtools/client/netmonitor/src/connector/firefox-connector.js#201

Honza

I’ll take a crack at it as my first bug🙂

Assignee: nobody → duncangleeddean
Status: NEW → ASSIGNED

Awesome, thanks for the help!
Honza

Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e45f7a332126
Stop ongoing search after reload. r=Honza
Blocks: 1584547
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72

Jan, do you want to request an uplift to our RC build or can it ship in 72?

Flags: needinfo?(jvarga)
Flags: needinfo?(jvarga) → needinfo?(odvarko)

Comment on attachment 9110643 [details]
Bug 1598285 - Stop ongoing search after reload. r=Honza!

Beta/Release Uplift Approval Request

  • User impact if declined: Wrong search label. Indicates that search is in progress, which might be confusing to the user.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Low risk, only for developers, a few line of code.
  • String changes made/needed:
Flags: needinfo?(odvarko)
Attachment #9110643 - Flags: approval-mozilla-beta?

Comment on attachment 9110643 [details]
Bug 1598285 - Stop ongoing search after reload. r=Honza!

The patch is minimal and this bug is the reason why the feature got a yellow signoff from QA, I am taking it for RC.

Attachment #9110643 - Flags: approval-mozilla-beta? → approval-mozilla-release+

Hello Marcela, please take a look when you have time.

Flags: qe-verify+
Flags: needinfo?(marcela.calderon)
QA Whiteboard: [qa-triaged]

Verified fixed in latest Nightly 72.0a1 Build ID 20191126093448 and Firefox Release 71.0 Build ID 20191125204040 on Windows 10 x64, macOS 10.14 and Ubuntu 18.04 x64.

Flags: needinfo?(marcela.calderon)
Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.