text on page is overlapping in the MS knowledge base

VERIFIED DUPLICATE of bug 159494

Status

--
minor
VERIFIED DUPLICATE of bug 159494
17 years ago
14 years ago

People

(Reporter: SingCP, Assigned: Matti)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
I have seen the problem on several pages in the MS knowledge base. The symptom
is lines of text overlapping and is present and reproducable on my machine in
Mozilla 1.0 but not in IE 5.5. In this case the problem is visable in the top
white section on the right hand side.

On at least one page in the kb the offending text was in red rather than the
black text IE displayed. I am no programmer but the relevant section of html is
probably it the following.


<div class="KBPUBV1" name="KBPUBV1"><!-- - - - - - - - - - - PAGE TEXT BEGINS
BELOW HERE - - - - - - - - - - --><h1 class="title">BUG: MSCDEX May Not Detect
Disk Change</h1><div class="preappliesto"></div><div class="appliesto">The
information in this article applies to:<ul><li>

Microsoft CD-ROM Extensions (MSCDEX) for MS-DOS 2.0, 2.1, 2.2, 2.21, 2.22,
2.23</li><li>
Microsoft Windows Software Development Kit (SDK) 3.1</li></ul></div><div
class="postappliesto"></div><div class="SYMPTOMS"><h2>Symptoms</h2>


I am using in intel p3 platform with win2000 sp2 and hotfixes build is 5.00.2195.

Mozilla build is 2002053012.

Comment 1

17 years ago
This is a duplicate. The "appliesto" class has several negative margin settings,
so it is likely not a Mozilla bug at all but bad CSS on Microsoft's part.
Whenever you have "margin-top: -1em" you can expect some overlapping.

Note the empty <div class="preappliesto"></div>. I guess if it is inappropriate
cheating with nbsp;, empty P:s and multiple BR:s, the new paradigm is to cheat
with CSS classes in empty DIV:s.

Code sucks, in other words.

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 159494 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
v.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.