Last Comment Bug 159853 - Tab Manager (list of tabs and windows)
: Tab Manager (list of tabs and windows)
Status: RESOLVED DUPLICATE of bug 323315
:
Product: SeaMonkey
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: Trunk
: All All
: -- enhancement with 3 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://weblogs.mozillazine.org/roc/ar...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-28 16:17 PDT by leonard
Modified: 2012-06-04 19:32 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
IE7's implementation of this feature (82.99 KB, image/jpeg)
2005-10-13 06:25 PDT, Jon Henry
no flags Details

Description leonard 2002-07-28 16:17:40 PDT
As most people love tabs, and use them as a way to help categorize/organize
their browsing, and especially now with the ability to bookmark groups of tabs,
it would be great if there was a tab manager tool that could be launched that
would allow one to see what tabs are open in which Mozilla windows and give the
ability to reparent tabs to facilitate organization and bookmarking.
Comment 1 david9789 2002-07-28 17:44:27 PDT
leonard@acm.org - could you please read the Bug Writing Guidelines at 
<http://www.mozilla.org/quality/bug-writing-guidelines.html> to see the
kinds of information we need in a bug report. Please report back with more
information (like BuildID and steps to reproduce) after reading those
guidelines and consider using the Bugzilla Helper to report future
bugs. 

The Helper can be found at <http://www.mozilla.org/quality/help/bug-form.html>  
Thanks for your help in testing Mozilla.

David
Comment 2 leonard 2002-07-28 19:12:55 PDT
David, I am aware of both the Bugzilla Helper and the the Bugwriting Guidelines.
 Did you even read the bug before posting this boilerplate?  This is an RFE. 
Therefore there are no relevant BuildIDs or steps to reproduce.  The feature
doesn't exist (yet, hoepfully).
Comment 3 Jesse Ruderman 2002-08-05 09:34:38 PDT
Opera has a "List Windows" feature in its Window menu, but it doesn't let you 
see or copy URLs.
Comment 4 Jon Henry 2005-10-13 06:25:59 PDT
Created attachment 199414 [details]
IE7's implementation of this feature

I recently saw some screenshots of IE7 running on Windows Vista, and they
suggest that IE will solve this problem using something like OSX's "Exposé"
feature. I don't know the actal mechanics of how it works since it's just a
screenshot, but they seem to show a thumbnail of each open tab along with its
title. Presumably left-clicking the image would activate that tab, and
right-clicking could bring up options like "Copy URL" and "Bookmark this page".


roc's "render webpages to image" technology could make implementing this
feasible. See his blog:
http://weblogs.mozillazine.org/roc/archives/2005/05/rendering_web_p.html
Comment 5 Philip Chee 2005-11-03 07:15:34 PST
Ted Mielczarek's Expose-like extension for Firefox 1.5:
<http://forums.mozillazine.org/viewtopic.php?t=333782&postsperpage=45&start=0>
Comment 6 Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com] 2006-01-29 11:50:29 PST
Duping to bug that has partial implementation

*** This bug has been marked as a duplicate of 323315 ***
Comment 7 Scott Tankard 2006-01-30 09:59:13 PST
Chris Thomas, bug 323315 is a bug for the Mozilla App Suite. Should that bug be changed?

In addition, I think the original intention of this bug was to have a list, not a thumbnail layer. It would work very well to integrate a revive-window/tab function (bug 152391 and 39165) into the list.

Note You need to log in before you can comment on or make changes to this bug.