Closed Bug 1598616 Opened 5 years ago Closed 4 years ago

"@google" is not handled when we pass the search string directly to the docshell (due to results being late)

Categories

(Firefox :: Address Bar, defect, P3)

72 Branch
defect
Points:
3

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox75 --- wontfix
firefox78 --- fixed

People

(Reporter: wtds.trabalho, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:72.0) Gecko/20100101 Firefox/72.0

Steps to reproduce:

When search for something in new page search bar(redirect focus to navbar)
or in urlbar, when paste text em arrow down to Google icon:

The "@google" appears in google search string, shouldn't be ommited?
https://www.google.com/search?client=firefox-b-d&q=%40google+%2Flib64%2Flibnss_files-2.22.so

Example:
https://www.google.com/search?client=firefox-b-d&q=%40google+%2Flib64%2Flibnss_files-2.22.so

Actual results:

Sometimes(I can find precise scenario or action sequence)

The search attached "@google" in query string from navbar search.

Expected results:

Reporting to inform, and make visible if somebody else will have the same problem.

Thanks!

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Address Bar

Yes, @google should not appear in the search string.
It would be nice to have better detailed steps to reproduce the problem, because I can't reproduce it.
Could you please help us finding at least one reproducible case where this happens?

Flags: needinfo?(wtds.trabalho)
Summary: Search from new or navbar page, attaching arroba 'google' in query string (Sometimes) → Sometimes "@google" appears in the search string when searching from the new tab or urlbar

Hi Marco,

The problem origin is like my others recent bugs, just a slow, versy slow PC.
Please try slowdown your scenario of test or use a limited PC to try reproduce this.

I only can reproduce in moments of high IO disk usage. But there isn't logs or debugs to help find the precise origin of the problem.

Thanks!

Flags: needinfo?(wtds.trabalho) → needinfo?(mak)

I see, I suspect that we cross the UrlbarEventBufferer.jsm 200ms timeout while waiting for the first result, we handle enter directly and just pass the @google something string to the docshell, that can't handle it.

We should add directly handling of @tokens in the fallback code (URIFIxup likely?), and maybe increase the timer a bit.

Status: UNCONFIRMED → NEW
Points: --- → 3
Ever confirmed: true
Flags: needinfo?(mak)
Priority: -- → P3
Summary: Sometimes "@google" appears in the search string when searching from the new tab or urlbar → "@google" is not handled when we pass the search string directly to the docshell (due to results being late)
Depends on: 1496578

Updating qe tracking flags to reflect QA triage decision taken with :mdeboer in QA-Search weekly sync meeting.

Flags: qe-verify+

This is similar to Bug 1604927.
Unfortunately, if my theory in comment 4 would be correct, we should land in UrlbarInput::handleCommand and more specifically in UrlbarUtils.getShortcutOrURIAndPostData, that afaict handles token aliases properly. Indeed even with paste & go or escaping the results, I can't reproduce this.

I'm not sure what's up.

See Also: → 1604927

I think this should not happen anymore now that in bug 1636583 I made us always go through a UrlbarResult and not straight to the docshell.

Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Depends on: 1636583
Severity: normal → S3
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: