Closed Bug 1598960 Opened 2 months ago Closed 2 months ago

High Frequency toolkit/modules/tests/xpcshell/test_FinderIterator.js | test_parallel_starts - [test_parallel_starts : 330] Not all ranges should've been found - 2143 < 2143 - when Gecko 72 merges to Beta on 2019-12-02

Categories

(Toolkit :: Find Toolbar, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
thunderbird_esr60 --- unaffected
thunderbird_esr68 --- unaffected
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- unaffected
firefox72 + unaffected

People

(Reporter: dluca, Unassigned)

Details

(Keywords: regression)

[Tracking Requested - why for this release]:

[Tracking Requested - why for this release]:
Central as Beta:
https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Cretry%2Cusercancel%2Crunnable&revision=6a8bf060cd61aaf932395d9b306b7fdfcac7d612&selectedJob=277881280

Failure log:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=277881280&repo=try&lineNumber=3561

 INFO -  TEST-PASS | toolkit/modules/tests/xpcshell/test_FinderIterator.js | test_parallel_starts - [test_parallel_starts : 301] We ought to be running here - true == true
[task 2019-11-24T11:46:24.287Z] 11:46:24     INFO -  "CONSOLE_MESSAGE: (error) [JavaScript Error: "FinderIterator Error: TypeError: listener[callback] is not a function" {file: "resource://gre/modules/FinderIterator.jsm" line: 363}]
[task 2019-11-24T11:46:24.287Z] 11:46:24     INFO -  _notifyListeners@resource://gre/modules/FinderIterator.jsm:363:12
[task 2019-11-24T11:46:24.287Z] 11:46:24     INFO -  _yieldIntermediateResult@resource://gre/modules/FinderIterator.jsm:515:10
[task 2019-11-24T11:46:24.287Z] 11:46:24     INFO -  start@resource://gre/modules/FinderIterator.jsm:194:12
[task 2019-11-24T11:46:24.287Z] 11:46:24     INFO -  test_parallel_starts@test_FinderIterator.js:304:34
[task 2019-11-24T11:46:24.287Z] 11:46:24     INFO -  _do_main@/sdcard/tests/xpc/head.js:246:6
[task 2019-11-24T11:46:24.288Z] 11:46:24     INFO -  _execute_test@/sdcard/tests/xpc/head.js:573:5
[task 2019-11-24T11:46:24.288Z] 11:46:24     INFO -  @-e:1:1
[task 2019-11-24T11:46:24.288Z] 11:46:24     INFO -  "
[task 2019-11-24T11:46:24.288Z] 11:46:24     INFO -  TEST-PASS | toolkit/modules/tests/xpcshell/test_FinderIterator.js | test_parallel_starts - [test_parallel_starts : 320] Stop means stop - true == true
[task 2019-11-24T11:46:24.288Z] 11:46:24     INFO -  TEST-PASS | toolkit/modules/tests/xpcshell/test_FinderIterator.js | test_parallel_starts - [test_parallel_starts : 325] At least one range should've been found - 2143 > 100
[task 2019-11-24T11:46:24.288Z] 11:46:24  WARNING -  TEST-UNEXPECTED-FAIL | toolkit/modules/tests/xpcshell/test_FinderIterator.js | test_parallel_starts - [test_parallel_starts : 330] Not all ranges should've been found - 2143 < 2143
[task 2019-11-24T11:46:24.288Z] 11:46:24     INFO -  test_FinderIterator.js:test_parallel_starts:330
[task 2019-11-24T11:46:24.288Z] 11:46:24     INFO -  /sdcard/tests/xpc/head.js:_do_main:246
[task 2019-11-24T11:46:24.288Z] 11:46:24     INFO -  /sdcard/tests/xpc/head.js:_execute_test:573
[task 2019-11-24T11:46:24.288Z] 11:46:24     INFO -  -e:null:1
[task 2019-11-24T11:46:24.288Z] 11:46:24     INFO -  exiting test
[task 2019-11-24T11:46:24.288Z] 11:46:24     INFO -  Unexpected exception NS_ERROR_ABORT:
[task 2019-11-24T11:46:24.289Z] 11:46:24     INFO -  _abort_failed_test@/sdcard/tests/xpc/head.js:791:20
[task 2019-11-24T11:46:24.289Z] 11:46:24     INFO -  do_report_result@/sdcard/tests/xpc/head.js:892:5
[task 2019-11-24T11:46:24.289Z] 11:46:24     INFO -  Assert<@/sdcard/tests/xpc/head.js:67:21
[task 2019-11-24T11:46:24.289Z] 11:46:24     INFO -  proto.report@resource://testing-common/Assert.jsm:233:10
[task 2019-11-24T11:46:24.289Z] 11:46:24     INFO -  compareNumbers@resource://testing-common/Assert.jsm:501:10
[task 2019-11-24T11:46:24.289Z] 11:46:24     INFO -  less@resource://testing-common/Assert.jsm:556:18
[task 2019-11-24T11:46:24.289Z] 11:46:24     INFO -  test_parallel_starts@test_FinderIterator.js:330:10
[task 2019-11-24T11:46:24.289Z] 11:46:24     INFO -  _do_main@/sdcard/tests/xpc/head.js:246:6
[task 2019-11-24T11:46:24.289Z] 11:46:24     INFO -  _execute_test@/sdcard/tests/xpc/head.js:573:5
[task 2019-11-24T11:46:24.289Z] 11:46:24     INFO -  @-e:1:1
[task 2019-11-24T11:46:24.289Z] 11:46:24     INFO -  exiting test
[task 2019-11-24T11:46:24.289Z] 11:46:24     INFO -  <<<<<<<
[task 2019-11-24T11:46:27.223Z] 11:46:27     INFO -  TEST-START | toolkit/modules/tests/xpcshell/test_GMPInstallManager.js
[task 2019-11-24T11:46:27.939Z] 11:46:27     INFO -  TEST-PASS | toolkit/modules/tests/xpcshell/test_GMPInstallManager.js | took 717ms

Bianca: Could your recent changes to Bug 1573201 have anything to do with the spike in frequency of this bug?

Flags: needinfo?(bdanforth)

We (rpl and I) took a look at this test, which relates to the Find Bar, and we don't think there is any chance that the change landed in Bug 1573201 would produce this higher intermittency. Bug 1573201 makes a change to a storage actor in the DevTools Storage panel for Addon toolboxes only and moves some DevTools files from the client to a shared directory. We didn't change anything in the WebExtensions framework for example.

Looking at the pushlog, there are many other changes that landed at the same time. How do you detect which change(s) may be the cause inside of a larger push like this (e.g. mozregression)?

Please note: I will be out of the office for the next week, so if there is any follow-up related to Bug 1573201, please contact rpl in my absence.

Flags: needinfo?(bdanforth)

This doesn't seem to actually affect mozilla-beta since the merge.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.