Closed Bug 1599145 Opened 1 year ago Closed 1 year ago

Investigate "clientId missing" validation errors in deletion-request pings

Categories

(Toolkit :: Telemetry, task, P1)

task
Points:
2

Tracking

()

RESOLVED FIXED
mozilla73
Tracking Status
firefox-esr68 --- unaffected
firefox71 --- unaffected
firefox72 --- fixed
firefox73 --- fixed

People

(Reporter: chutten, Assigned: chutten)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Out of the 372 "deletion-request" pings we've received this past week, 5 failed to be handled by GCP's schema validation. All 5 failed because they had no "clientId".

This might be a single build being weird. This might be all from the same client (without a clientId how would we even know). This could mean that Jan-Erik was right and "deletion-request" pings can be sent early enough in startup that we haven't cached the clientId yet.

As 5 of 372 is more than the 1% weirdness threshold (the threshold below which we shrug as we get the weirdest stuff), this requires investigation.

We're up to 11 of 615 pings now. They come in on a variety of days at a variety of times, 10 from Linux and 1 from Mac (according to User-Agent), and all with unique document ids (according to the submission url).

To me this suggests that these are legitimate submissions from at least two profiles. The only known path by which this could happen legitimately is the one Jan-Erik suggested, so I guess I should patch that up and see if it fixes things.

Pushed by chutten@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/470a0c802675
Ensure we load the client id before sending the deletion-request ping. r=janerik
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73

"deletion-request" pings are still coming in with expected frequency on Nightly (and on beta, too, with a commensurate increase in volume), and as of Nov 28 (a few days before my patch landed) we've seen none of them missing their clientId.

There was one on the 4th that had a JSON decoding error, but I think we can attribute that to noise.

Looks like this is verified on Nightly, so let's get it uplifted to Beta 72.

Comment on attachment 9112340 [details]
Bug 1599145 - Ensure we load the client id before sending the deletion-request ping. r?janerik

Beta/Release Uplift Approval Request

  • User impact if declined: The "deletion-request" ping might not contain the id telling us which data we're being asked to delete.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small timing patch making the code a little less dependent on the user waiting for Firefox to properly start before opting out of data collection.
  • String changes made/needed:
Attachment #9112340 - Flags: approval-mozilla-beta?

Comment on attachment 9112340 [details]
Bug 1599145 - Ensure we load the client id before sending the deletion-request ping. r?janerik

fix for deletion-request pings, approved for 72.0b3

Attachment #9112340 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.