Closed Bug 1599307 Opened 10 months ago Closed 7 months ago

What's New panel: In light theme, the background should be white

Categories

(DevTools :: What's New, defect, P3)

defect

Tracking

(firefox70 wontfix, firefox71 wontfix, firefox72 wontfix, firefox73 wontfix, firefox74 wontfix, firefox75 verified)

VERIFIED FIXED
Firefox 75
Tracking Status
firefox70 --- wontfix
firefox71 --- wontfix
firefox72 --- wontfix
firefox73 --- wontfix
firefox74 --- wontfix
firefox75 --- verified

People

(Reporter: victoria, Assigned: aarushivij)

References

Details

(Keywords: good-first-bug)

Attachments

(2 files)

Currently the hover color is a bit hard to see in light theme since it clashes with the light gray background. We should change the background to be white instead.

Thanks again Victoria!

Notes :

  • "The highlight color is correct, but the light theme background color is not. It should be white rather than gray"
  • attaching a screenshot with the current issue, contrast for light theme should be improved based on the above note;
  • additional info on the issue can be found here;

Affected builds:
71.0, 71.0b12, 72.0a1 (2019-11-17);

Blocks: 1598624
OS: Unspecified → All
Hardware: Unspecified → All
Version: unspecified → Trunk

The priority flag is not set for this bug.
:Harald, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(hkirschner)
Flags: needinfo?(hkirschner)
Keywords: good-first-bug
Priority: -- → P3

Hi. I am interested in taking this bug. Can you tell me in which file(s) does the code resides pertaining to the problem?

Thanks :)

Flags: needinfo?(cristian.fogel)

Sorry for the late reply, was out of office.
Harald should have the best context for this.

Flags: needinfo?(cristian.fogel) → needinfo?(hkirschner)

Thanks for offering to help, I assigned you the bug. Everything is in https://searchfox.org/mozilla-central/source/devtools/client/whats-new, src holds the CSS.

Assignee: nobody → sharma.divyansh.501
Status: NEW → ASSIGNED
Flags: needinfo?(hkirschner) → needinfo?(sharma.divyansh.501)

Hi Harald, thanks for directing me to the existing code. I am unable to find attribute that will change the background color. I tried to change values to different background colors to white, but to no use. Can you help me?

Flags: needinfo?(sharma.divyansh.501) → needinfo?(hkirschner)

li > a:hover changes the hover color and not the background color. Please clarify on this.

Flags: needinfo?(hkirschner)

Hello
Can I work on this issue?
Thanks
Aarushi

Looks like this panel doesn't have an existing background color. Other panels like Accessibility and Performance set a .theme-body class on the body tag which includes the right background color. That's probably what we should do here.

Divyansh, let me know if you're still interested in fixing this bug, or I can free it up for Aarushi.

Thanks!

Flags: needinfo?(hkirschner) → needinfo?(sharma.divyansh.501)

@victoria
Can I work on this issue
Thanks :)
Aarushi

Assignee: sharma.divyansh.501 → aarushivij

Okay, I've reassigned this to Aarushi.

Divyansh, feel free to pick up a different bug if you're interested in contributing again.

Flags: needinfo?(sharma.divyansh.501)
Attachment #9126213 - Attachment description: Bug 1599307 - What's New panel: In light theme, the background should be white. r=victoria → Bug 1599307 - Set What's New panel background to white in light mode. r=nchevobbe.
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/de02a2ee356a
Set What's New panel background to white in light mode. r=nchevobbe.

Thanks @nchevobbe :)
Aarushi

Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 75

Is this something we should consider for Beta uplift?

Flags: needinfo?(nchevobbe)

I think that's fine, even if the current color is not perfect, it's not terrible either.

Flags: needinfo?(nchevobbe)
Flags: qe-verify+
QA Contact: cristian.fogel

Confirmed with Victoria as well, while not ideal there is an improvement from before.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.