java applets crashes mozilla

RESOLVED WORKSFORME

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED WORKSFORME
16 years ago
7 years ago

People

(Reporter: david, Assigned: Joe Chou)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1a) Gecko/20020702
BuildID:    20020702

What can i say.
Java applets crashes mozilla.
Java plugin is libjavaplugin_oji.so from j2sdk1.4.0_01 from sun.
can test in any page with a java applet (dont have url because crashes before i
can write it down)

btw, here Build ID is shown as 0000000000 (might be unicode stuff) in Gnome 2.

Reproducible: Always
Steps to Reproduce:
1.Install the rpms for mozilla 1.1a
2.Install sun's java j2sdk1.4.0_01's plugin.
3. Load any page with a java applet

Actual Results:  Mozilla crashes

Expected Results:  Applet loaded and running

How possible is it that java crashes and it crashes mozilla?
If its java crashing, shouldnt it not crash mozilla?

Comment 1

16 years ago
Have you properly symlinked the plugin or did you copy it? (asking since copying
is a common mistake)

Updated

16 years ago
Keywords: crash, stackwanted

Comment 2

16 years ago
Since netscape doesnt' bundle jre 1.4.0_01, it bundles with jre 1.3.1_02 only.
Anyway, I tested on jre 1.4.1beta, I properly symlinked and it worked fine 
without crashing on my linux redhat 7.3, (netscape branch build: 
2002-07-26-06-1.0.0).

Comment 3

16 years ago
Just want to add more info in this bug:
Since netscape doesn't bundle jre 1.4.0_01 for linux, it bundles with jre 
1.3.1_02 only.

Comment 4

16 years ago
Reporter,

Can you provide any more information about this problem?  Have you tried 1.4.1rc?

Comment 5

15 years ago
WFM - no response from reporter
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

15 years ago
QA Contact: pmac → petersen

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.