Closed Bug 1599407 Opened 1 year ago Closed 1 year ago

Fix scrolling at narrow widths in the Computed View

Categories

(DevTools :: Inspector, defect, P2)

defect

Tracking

(firefox73 fixed)

RESOLVED FIXED
Firefox 73
Tracking Status
firefox73 --- fixed

People

(Reporter: miker, Assigned: miker)

References

Details

Attachments

(1 file)

When resizing this to make it narrow, we hit its minimum size when the "Browser Styles" checkbox cannot fit anymore horizontally on the same line as the search field. So adding a scrollbar after that seems good too.

The problem is that when you do scroll, this also scrolls the toolbar (search field + checkbox). I think it might be better to only scroll the list of properties if they don't fit. 3 other improvements I can think of (which could be in a follow-up bug):

  • Give the search field an event smaller min size so it can shrink even further
  • Use an ellipsis for the "Browser Styles" label
  • When things really don't fit anymore, drop the checkbox to a second line (below the search field)
Component: Inspector → Inspector: Computed
Assignee: nobody → mratcliffe
Pushed by mratcliffe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0ff840899e59
Fix scrolling at narrow widths in the Computed View r=pbro
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 73
Component: Inspector: Computed → Inspector
You need to log in before you can comment on or make changes to this bug.