Closed Bug 1599424 Opened 1 year ago Closed 1 year ago

Convert vismet task output to a perfherder artifact

Categories

(Testing :: Raptor, enhancement, P1)

Version 3
enhancement

Tracking

(firefox73 fixed)

RESOLVED FIXED
mozilla73
Tracking Status
firefox73 --- fixed

People

(Reporter: tarek, Assigned: tarek)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

This is a follow-up bug from bug 1595789

let's simplify and clean up the vismet task:

  • remove the schema stuff in the decision task, we don't use anymore

https://searchfox.org/mozilla-central/source/taskcluster/taskgraph/util/schema.py#132
https://searchfox.org/mozilla-central/source/taskcluster/taskgraph/decision.py#120

  • simplify the vismet output.

=> currently: a tarball with one dir per result, with browsertime.json, pages/ and visual-metrics.json
=> proposed: a single file called visual-metrics.json, containing an indexed list of all results from each /<index>/visual-metrics.json file

This would be great to have! Could that simplified JSON be in a perfherder-data format so we can start monitoring the results?

There's another bug on file for dumping out visual metric results to Perfherder: Bug 1592262

Priority: -- → P2
Duplicate of this bug: 1592262
Summary: Simplify vismet output → Convert vismet task output to a perfherder artifact
Assignee: nobody → tarek
Priority: P2 → P1
Blocks: 1601414
Pushed by tziade@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fc1a07c0d43f
Convert vismet task output to a perfherder artifact r=sparky,rwood
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
You need to log in before you can comment on or make changes to this bug.