Trunk M17rc1 crashes [@ nsImageWin::DrawToImage]

RESOLVED FIXED in mozilla1.4alpha

Status

Core Graveyard
GFX
P1
critical
RESOLVED FIXED
16 years ago
9 years ago

People

(Reporter: greer, Assigned: tor)

Tracking

(4 keywords)

Trunk
mozilla1.4alpha
x86
Windows 2000
crash, qawanted, topcrash, verified1.7
Bug Flags:
blocking1.7 +

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
This unique stack is occuring enough to make it to the top 20 of the current
Trunk crashes. It looks like a dupe of bug 153815 (see comment #9 in that bug)
and the timer issues that we are seeing there. 

Stack trace(Frame) 

	 nsImageWin::DrawToImage
[c:/builds/seamonkey/mozilla/gfx/src/windows/nsImageWin.cpp  line 1609] 
	 gfxImageFrame::DrawTo
[c:/builds/seamonkey/mozilla/gfx2/src/gfxImageFrame.cpp  line 420] 
	 imgContainer::DoComposite
[c:/builds/seamonkey/mozilla/modules/libpr0n/src/imgContainer.cpp  line 647] 
	 imgContainer::Notify
[c:/builds/seamonkey/mozilla/modules/libpr0n/src/imgContainer.cpp  line 459] 
	 nsTimerImpl::Fire
[c:/builds/seamonkey/mozilla/xpcom/threads/nsTimerImpl.cpp  line 352] 
	 nsTimerManager::FireNextIdleTimer
[c:/builds/seamonkey/mozilla/xpcom/threads/nsTimerImpl.cpp  line 588] 
	 nsAppShell::Run
[c:/builds/seamonkey/mozilla/widget/src/windows/nsAppShell.cpp  line 134] 
	 nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp  line 452] 
	 main1
[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1527] 
	 main
[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1874] 
	 WinMain
[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1892] 
	 WinMainCRTStartup()  
	 kernel32.dll + 0x1eb69 (0x77e7eb69)   
 
     (8748687)	URL: http://www.penny-arcade.com
     (8748687)	Comments: opening sites in tabs
     (8747587)	URL: http://www.segundamano.es
     (8737879)	URL: www.sinfest.net
     (8737879)	Comments: Browser crashed while page was loading.
     (8732841)	URL: http://www.joyoftech.com/joyoftech/
     (8723888)	Comments: loading www.schlockmercenary.com
     (8701156)	URL: www.sinfest.net
     (8685049)	Comments: opened several tabs of comicpages  not sure which one (if any)
caused the crash
     (8652378)	URL: http://www.gpf-comics.com
(Reporter)

Comment 1

16 years ago
Duping to bug 153815, adding the topcrash- keyword so that Talkback sees this bug.

*** This bug has been marked as a duplicate of 153815 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Keywords: crash, topcrash-
Resolution: --- → DUPLICATE

Comment 2

16 years ago
I'm going to reopen this instead of logging a new bug.  This was duped to bug
153815, but while all the other stack signatures in that bug have disappeared
from Talkback data since the fix, this particular crash is still happening on
the Trunk and with Mozilla 1.2 Beta:

12   nsImageWin::DrawToImage   49
		 153815 	 RESO 	 FIXE 	 kin@netscape.com 	 mozilla1.2alpha 	 2002-10-21
		 159958 	 RESO 	 DUPL 	 pavlov@netscape.com 	 --- 	 2002-07-29 

 
 	Source File : c:/builds/seamonkey/mozilla/gfx/src/windows/nsImageWin.cpp line
: 1617
 
====================================================================================================
     Count   Offset    Real Signature
[ 9   nsImageWin::DrawToImage 12db4892 - nsImageWin::DrawToImage ]
[ 8   nsImageWin::DrawToImage 5f1eb26f - nsImageWin::DrawToImage ]
[ 7   nsImageWin::DrawToImage c8046ae0 - nsImageWin::DrawToImage ]
[ 7   nsImageWin::DrawToImage b55e5142 - nsImageWin::DrawToImage ]
[ 4   nsImageWin::DrawToImage 14ad0b50 - nsImageWin::DrawToImage ]
[ 1   nsImageWin::DrawToImage e82fe21d - nsImageWin::DrawToImage ]
[ 1   nsImageWin::DrawToImage dfeec3c0 - nsImageWin::DrawToImage ]
[ 1   nsImageWin::DrawToImage c4c6ceb8 - nsImageWin::DrawToImage ]
[ 1   nsImageWin::DrawToImage c41f7e1e - nsImageWin::DrawToImage ]
[ 1   nsImageWin::DrawToImage a4a45f00 - nsImageWin::DrawToImage ]
[ 1   nsImageWin::DrawToImage 8a43013a - nsImageWin::DrawToImage ]
[ 1   nsImageWin::DrawToImage 76b9919f - nsImageWin::DrawToImage ]
[ 1   nsImageWin::DrawToImage 65e89780 - nsImageWin::DrawToImage ]
 
     Crash date range: 2002-11-03 to 2002-11-13
     Min/Max Seconds since last crash: 2285 - 1313867
     Min/Max Runtime: 21296 - 2590320
     Keyword List : back(4), link(4), load(6),  
     Count   Platform List 
     22   Windows NT 5.0 build 2195
     12   Windows NT 4.0 build 1381
     9   Windows NT 5.1 build 2600
 
     Count   Build Id List 
     43   2002101612
 
     No of Unique Users        40
 
 Stack trace(Frame) 

	 nsImageWin::DrawToImage
[c:/builds/seamonkey/mozilla/gfx/src/windows/nsImageWin.cpp  line 1617] 
	 gfxImageFrame::DrawTo
[c:/builds/seamonkey/mozilla/gfx/src/shared/gfxImageFrame.cpp  line 425] 
	 imgContainerGIF::DoComposite
[c:/builds/seamonkey/mozilla/modules/libpr0n/decoders/gif/imgContainerGIF.cpp 
line 697] 
	 imgContainerGIF::Notify
[c:/builds/seamonkey/mozilla/modules/libpr0n/decoders/gif/imgContainerGIF.cpp 
line 509] 
	 nsTimerImpl::Fire	[c:/builds/seamonkey/mozilla/xpcom/threads/nsTimerImpl.cpp 
line 380] 
	 nsTimerManager::FireNextIdleTimer
[c:/builds/seamonkey/mozilla/xpcom/threads/nsTimerImpl.cpp  line 591] 
	 nsAppShell::Run	[c:/builds/seamonkey/mozilla/widget/src/windows/nsAppShell.cpp
 line 173] 
	 nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp  line 472] 
	 main1	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1538] 
	 main	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1886] 
	 WinMain	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1906] 
	 WinMainCRTStartup()  
	 KERNEL32.DLL + 0x1ca90 (0x77e9ca90)   
 
     (13874600)	URL: http://www.freewarepalm.com
     (13832138)	URL: www.kemiko.com
     (13832138)	Comments: I was hitting 'back' from the homepage.  It would of
still linked to another page at kemiko.  Probably to the one that shows a
"Preview of Stains"
     (13812351)	URL: http://www.dabsxchange.com/scripts/BiddingActivity.asp
     (13724855)	URL:
http://linux.oreillynet.com/pub/a/onlamp/2002/11/07/linux_threads.html
     (13722916)	URL: http://www.google.com + another url
     (13682557)	URL: http://www.freewarepalm.com
     (13682557)	Comments: Just started loading site.  I assume one of the ad
delivery mechanisms caused the problem.  Other than this Mozilla 1.2b has been
remarkedly stable in daily use.
     (13680563)	URL: www.palm.com
     (13680563)	Comments: browsing palm website 3rd tab open. 1st tab my.yahoo
2nd tab yahoo.mail clicked on products and booommm
     (13672202)	URL: www.fool.co.uk
     (13672202)	Comments: loading the fool index page
     (13621425)	URL: www.xml.com
     (13621425)	Comments: Moving from www.byca.supanet.com to www.xml.com.   
there is something about the Java that www.byca.supanet.com that Mozilla does
not like  as it often crashes or freezes on that page
     (13617921)	URL: http://www.everythingjake.com
     (13617921)	Comments: I opened a bookmark with about 14 tabs (comics urls 
dilbert  keenspot  etc..) when mozilla crashed. Happened midway from closing the
tabs
     (13531810)	URL: www.fool.co.uk
     (13531810)	Comments: loading up the home page of the motley fool UK
     (13522394)	URL: www.hostingguide.co.uk
     (13522394)	Comments: selecting from the web space drop down list
     (13455030)	URL: practicallynetworked.com
     (13455030)	Comments: reading
 
====================================================================================================
     Count   Offset    Real Signature
[ 1   nsImageWin::DrawToImage c3f19be6 - nsImageWin::DrawToImage ]
 
     Crash date range: 2002-11-06 to 2002-11-06
     Min/Max Seconds since last crash: 939321 - 939321
     Min/Max Runtime: 1384631 - 1384631
     Keyword List :  
     Count   Platform List 
     1   Windows NT 5.1 build 2600
 
     Count   Build Id List 
     1   2002101612
 
     No of Unique Users         1
 
 Stack trace(Frame) 

	 nsImageWin::DrawToImage
[c:/builds/seamonkey/mozilla/gfx/src/windows/nsImageWin.cpp  line 1617] 
	 gfxImageFrame::DrawTo
[c:/builds/seamonkey/mozilla/gfx/src/shared/gfxImageFrame.cpp  line 425] 
	 imgContainerGIF::DoComposite
[c:/builds/seamonkey/mozilla/modules/libpr0n/decoders/gif/imgContainerGIF.cpp 
line 677] 
	 imgContainerGIF::Notify
[c:/builds/seamonkey/mozilla/modules/libpr0n/decoders/gif/imgContainerGIF.cpp 
line 487] 
	 nsTimerManager::`scalar deleting destructor'  
	 PL_DestroyEventQueue	[c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c 
line 293] 
	 nsAppShell::Run	[c:/builds/seamonkey/mozilla/widget/src/windows/nsAppShell.cpp
 line 173] 
	 nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp  line 472] 
	 main1	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1538] 
	 main	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1886] 
	 WinMain	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1906] 
	 nsNativeAppSupportBase::GetIsServerMode
[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsNativeAppSupportBase.cpp  line 117] 
	 kernel32.dll + 0x214c7 (0x77e814c7)   
 
 
====================================================================================================
     Count   Offset    Real Signature
[ 1   nsImageWin::DrawToImage ab41c462 - nsImageWin::DrawToImage ]
 
     Crash date range: 2002-11-05 to 2002-11-05
     Min/Max Seconds since last crash: 198 - 198
     Min/Max Runtime: 2438 - 2438
     Keyword List :  
     Count   Platform List 
     1   Windows NT 5.0 build 2195
 
     Count   Build Id List 
     1   2002101612
 
     No of Unique Users         1
 
 Stack trace(Frame) 

	 nsImageWin::DrawToImage
[c:/builds/seamonkey/mozilla/gfx/src/windows/nsImageWin.cpp  line 1590] 
	 gfxImageFrame::DrawTo
[c:/builds/seamonkey/mozilla/gfx/src/shared/gfxImageFrame.cpp  line 425] 
	 0x00010000   

Please set this to the proper component and reassign as necessary.  Adding
qawanted keyword to see if anyone can reproduce this with recent builds.
Status: RESOLVED → REOPENED
Keywords: topcrash- → qawanted, topcrash
Resolution: DUPLICATE → ---
Summary: Timer related Trunk crashes [@ nsImageWin::DrawToImage] → Timer related Trunk M120B crashes [@ nsImageWin::DrawToImage]

Comment 3

16 years ago
cc'ing a few people from the old duped bug to see if there is anything that can
be done to deal with this remaining crash.

Comment 4

16 years ago
Still seeing lots of crashes in Mozilla 1.3 Alpha and MozillaTrunk builds.  We
need to get this reassigned if necessary so it gets looked at.  

Here are a set of crashes from M130A:
16   nsImageWin::DrawToImage   36
		 159958 	 REOP 	  	 pavlov@netscape.com 	 --- 	 2003-01-20
		 153815 	 RESO 	 FIXE 	 kin@netscape.com 	 mozilla1.2alpha 	 2002-11-29 

 
 	Source File : c:/builds/seamonkey/mozilla/gfx/src/windows/nsImageWin.cpp line
: 1617
 
====================================================================================================
     Count   Offset    Real Signature
[ 9   nsImageWin::DrawToImage 59dc6115 - nsImageWin::DrawToImage ]
[ 6   nsImageWin::DrawToImage 5f1eb26f - nsImageWin::DrawToImage ]
[ 4   nsImageWin::DrawToImage e82fe21d - nsImageWin::DrawToImage ]
[ 3   nsImageWin::DrawToImage 6b9fa6cd - nsImageWin::DrawToImage ]
[ 2   nsImageWin::DrawToImage c8046ae0 - nsImageWin::DrawToImage ]
[ 2   nsImageWin::DrawToImage b55e5142 - nsImageWin::DrawToImage ]
[ 1   nsImageWin::DrawToImage dfeec3c0 - nsImageWin::DrawToImage ]
[ 1   nsImageWin::DrawToImage a4a45f00 - nsImageWin::DrawToImage ]
[ 1   nsImageWin::DrawToImage 5dcfbc3d - nsImageWin::DrawToImage ]
[ 1   nsImageWin::DrawToImage 5c5e8710 - nsImageWin::DrawToImage ]
[ 1   nsImageWin::DrawToImage 2dc618ea - nsImageWin::DrawToImage ]
[ 1   nsImageWin::DrawToImage 14ad0b50 - nsImageWin::DrawToImage ]
[ 1   nsImageWin::DrawToImage 12db4892 - nsImageWin::DrawToImage ]
 
     Crash date range: 2003-01-17 to 2003-01-25
     Min/Max Seconds since last crash: 5461 - 954992
     Min/Max Runtime: 7261 - 1866142
     Keyword List :  
     Count   Platform List 
     15   Windows NT 5.0 build 2195
     11   Windows NT 5.1 build 2600
     7   Windows NT 4.0 build 1381
 
     Count   Build Id List 
     33   2002121215
 
     No of Unique Users        28
 
 Stack trace(Frame) 

	 nsImageWin::DrawToImage
[c:/builds/seamonkey/mozilla/gfx/src/windows/nsImageWin.cpp  line 1617] 
	 gfxImageFrame::DrawTo
[c:/builds/seamonkey/mozilla/gfx/src/shared/gfxImageFrame.cpp  line 425] 
	 imgContainerGIF::DoComposite
[c:/builds/seamonkey/mozilla/modules/libpr0n/decoders/gif/imgContainerGIF.cpp 
line 683] 
	 imgContainerGIF::Notify
[c:/builds/seamonkey/mozilla/modules/libpr0n/decoders/gif/imgContainerGIF.cpp 
line 493] 
	 nsTimerImpl::Fire	[c:/builds/seamonkey/mozilla/xpcom/threads/nsTimerImpl.cpp 
line 396] 
	 nsTimerManager::FireNextIdleTimer
[c:/builds/seamonkey/mozilla/xpcom/threads/nsTimerImpl.cpp  line 618] 
	 nsAppShell::Run	[c:/builds/seamonkey/mozilla/widget/src/windows/nsAppShell.cpp
 line 177] 
	 nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp  line 472] 
	 main1	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1560] 
	 main	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1908] 
	 WinMain	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1928] 
	 WinMainCRTStartup()  
	 KERNEL32.dll + 0x2847c (0x77ea847c)   
 
     (16605291)	URL: www.gathering.tweakers.net
     (16599317)	Comments: browsing tomshardware and olympus-nederland.com
     (16554448)	URL: http://www.freewarepalm.com
     (16522692)	URL: http://www.goats.com
     (16522692)	Comments: Attempting to visit http://www.goats.com using a
bookmark  just after visiting http://www.genecatlow.com
     (16474903)	URL: http://www.extremetech.com/article2/0 3973 799164 00.asp
     (16456488)	Comments: visited the site for Computer Music magazine (UK)
     (16438447)	URL: www.fark.com
     (16379179)	Comments: Moving non-mozilla window  mozilla was already unfocused.
     (16378995)	Comments: Moving non-mozilla window  mozilla was already unfocused.
     (16300553)	URL: www.winsms.org
     (16293669)	URL: www.freewarepalm.com
 
Anyone have an idea of what's going wrong here?  I'll try to reproduce this if I
can so we can get this topcrash+'d.
Summary: Timer related Trunk M120B crashes [@ nsImageWin::DrawToImage] → Timer related Trunk M130A crashes [@ nsImageWin::DrawToImage]

Comment 5

15 years ago
On 10/23/02 dcone made a change in the file gfxImageFrame.cpp involving image
depth: 'API change so we can create different depth nsImages'.  That comes just
before the call to nsImageWin::DrawToImage in the file nsImageWin.cpp which
crashes at line 1617:

1616 
1617   (*aBHead)->biSize = sizeof(BITMAPINFOHEADER);
1618   (*aBHead)->biWidth = aWidth;
1619   (*aBHead)->biHeight = aHeight;
1620   (*aBHead)->biPlanes = 1;
1621   (*aBHead)->biBitCount = (WORD)aDepth;
1622   (*aBHead)->biCompression = BI_RGB;
1623   (*aBHead)->biSizeImage = 0;            // not compressed, so we dont need
this to be set
1624   (*aBHead)->biXPelsPerMeter = 0;
1625   (*aBHead)->biYPelsPerMeter = 0;
1626   (*aBHead)->biClrUsed = numPaletteColors;
1627   (*aBHead)->biClrImportant = numPaletteColors;
1628  

Is it possible there's a relationship between that fix and this crash?

Comment 6

15 years ago
Changing component in hopes that someone can take a look at this soon.  It
continues to be a topcrasher with Mozilla 1.3 Beta.
Component: ImageLib → GFX
Summary: Timer related Trunk M130A crashes [@ nsImageWin::DrawToImage] → Trunk M130B crashes [@ nsImageWin::DrawToImage]

Comment 7

15 years ago
Reassigning to owner of GFX.
Assignee: pavlov → kmcclusk
Status: REOPENED → NEW
QA Contact: tpreston → ian

Comment 8

15 years ago
changing QA Contact to petersen
QA Contact: ian → petersen
Simon can you take a look when you get a chance?
Assignee: kmcclusk → smontagu
Priority: -- → P1
Target Milestone: --- → mozilla1.4alpha

Comment 10

15 years ago
Just updating summary with M140A since this continues to be a topcrash for
Mozilla 1.4 Alpha.  All the incidents are showing Windows 2K and XP.   Here is
the latest stack from M140A:

Stack trace(Frame) 

	 nsImageWin::DrawToImage
[c:/builds/seamonkey/mozilla/gfx/src/windows/nsImageWin.cpp  line 1827] 
	 gfxImageFrame::DrawTo
[c:/builds/seamonkey/mozilla/gfx/src/shared/gfxImageFrame.cpp  line 415] 
	 imgContainerGIF::DoComposite
[c:/builds/seamonkey/mozilla/modules/libpr0n/decoders/gif/imgContainerGIF.cpp 
line 656] 
	 imgContainerGIF::Notify
[c:/builds/seamonkey/mozilla/modules/libpr0n/decoders/gif/imgContainerGIF.cpp 
line 439] 
	 nsTimerImpl::Fire	[c:/builds/seamonkey/mozilla/xpcom/threads/nsTimerImpl.cpp 
line 395] 
	 nsTimerManager::FireNextIdleTimer
[c:/builds/seamonkey/mozilla/xpcom/threads/nsTimerImpl.cpp  line 616] 
	 nsAppShell::Run	[c:/builds/seamonkey/mozilla/widget/src/windows/nsAppShell.cpp
 line 176] 
	 nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp  line 480] 
	 main1	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1287] 
	 main	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1645] 
	 WinMain	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1666] 
	 WinMainCRTStartup()  
	 kernel32.dll + 0x214c7 (0x77e814c7)   
 
     (18803747)	URL: www.spiegel.de
Summary: Trunk M130B crashes [@ nsImageWin::DrawToImage] → Trunk M140A crashes [@ nsImageWin::DrawToImage]

Comment 11

14 years ago
This has been around for a while and continues to crash Mozilla 1.7 beta (I
think the last time we looked at this, it was crashing 1.4).  Here is some
talkback data:

Count   Offset    Real Signature
[ 14   nsImageWin::DrawToImage e82fe21d - nsImageWin::DrawToImage ]
[ 5   nsImageWin::DrawToImage 6b9fa6cd - nsImageWin::DrawToImage ]
[ 4   nsImageWin::DrawToImage cb37b45b - nsImageWin::DrawToImage ]
[ 3   nsImageWin::DrawToImage c8046ae0 - nsImageWin::DrawToImage ]
[ 1   nsImageWin::DrawToImage c3056de0 - nsImageWin::DrawToImage ]
[ 1   nsImageWin::DrawToImage 95754046 - nsImageWin::DrawToImage ]
[ 1   nsImageWin::DrawToImage 88c8bd9b - nsImageWin::DrawToImage ]
[ 1   nsImageWin::DrawToImage 430393b8 - nsImageWin::DrawToImage ]
[ 1   nsImageWin::DrawToImage 12db4892 - nsImageWin::DrawToImage ]
 
     Crash date range: 04-APR-04 to 10-APR-04
     Min/Max Seconds since last crash: 1097 - 1846680
     Min/Max Runtime: 1097 - 1846680
 
     Count   Platform List 
     22   [Windows NT 5.1 build 2600]   
     9   [Windows NT 5.0 build 2195]   
 
     Count   Build Id List 
     31   2004031615
 
     No of Unique Users        24
 
 Stack trace(Frame) 

	 nsImageWin::DrawToImage
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/gfx/src/windows/nsImageWin.cpp
 line 1893] 
	 gfxImageFrame::DrawTo
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/gfx/src/shared/gfxImageFrame.cpp
 line 419] 
	 imgContainerGIF::DoComposite
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/modules/libpr0n/decoders/gif/imgContainerGIF.cpp
 line 646] 
	 imgContainerGIF::Notify
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/modules/libpr0n/decoders/gif/imgContainerGIF.cpp
 line 432] 
	 nsTimerImpl::Fire
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/xpcom/threads/nsTimerImpl.cpp
 line 395] 
	 nsTimerManager::FireNextIdleTimer
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/xpcom/threads/nsTimerImpl.cpp
 line 616] 
	 nsAppShell::Run
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsAppShell.cpp
 line 142] 
	 nsAppShellService::Run
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/xpfe/appshell/src/nsAppShellService.cpp
 line 524] 
	 main1
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp
 line 1308] 
	 main
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp
 line 1712] 
	 WinMain
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp
 line 1734] 
	 WinMainCRTStartup()  
	 kernel32.dll + 0x214c7 (0x77e814c7)   
 
     (15179)	URL: cnn.com;foxnews com;aljazeera.com;fitday.com
     (15179)	Comments: I was opening up mu browser
     (12865)	URL: www.techbargains.com
     (12865)	Comments: reload

I will continue to try to reproduce...it's been tough.
Summary: Trunk M140A crashes [@ nsImageWin::DrawToImage] → Trunk M17alpha crashes [@ nsImageWin::DrawToImage]

Comment 12

14 years ago
Updating summary with M17rc1.  We should probably reassign this bug.  

Here is a recent crash with Mozilla 1.7 RC1:

Incident ID: 28634
Stack Signature	nsImageWin::DrawToImage e82fe21d
Email Address	
Product ID	Mozilla17
Build ID	2004042109
Trigger Time	2004-04-23 10:49:49.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	gkgfxwin.dll + (0000f675)
URL visited	www.foxnews.com
User Comments	Opened Mozilla and went to www.foxnews.com. Mozilla crashed. I
could see the opening page but then it bombed.
Since Last Crash	sec
Total Uptime	sec
Trigger Reason	Access violation
Source File Name
d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/gfx/src/windows/nsImageWin.cpp
Trigger Line No.	1893
Stack Trace 	
nsImageWin::DrawToImage
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/gfx/src/windows/nsImageWin.cpp,
line 1893]
gfxImageFrame::DrawTo
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/gfx/src/shared/gfxImageFrame.cpp,
line 419]
imgContainerGIF::DoComposite
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/modules/libpr0n/decoders/gif/imgContainerGIF.cpp,
line 646]
imgContainerGIF::Notify
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/modules/libpr0n/decoders/gif/imgContainerGIF.cpp,
line 432]
nsTimerImpl::Fire
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpcom/threads/nsTimerImpl.cpp,
line 395]
nsTimerManager::FireNextIdleTimer
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpcom/threads/nsTimerImpl.cpp,
line 616]
nsAppShell::Run
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsAppShell.cpp,
line 142]
nsAppShellService::Run
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpfe/appshell/src/nsAppShellService.cpp,
line 524]
main1
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 1313]
main
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 1783]
WinMain
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 1809]
WinMainCRTStartup()
kernel32.dll + 0x214c7 (0x77e814c7)
Assignee: smontagu → general
QA Contact: chrispetersen → ian
Summary: Trunk M17alpha crashes [@ nsImageWin::DrawToImage] → Trunk M17rc1 crashes [@ nsImageWin::DrawToImage]
(Assignee)

Comment 13

14 years ago
Created attachment 148231 [details] [diff] [review]
bit twiddling gone wrong...
Assignee: general → tor
Status: NEW → ASSIGNED
(Assignee)

Updated

14 years ago
Attachment #148231 - Flags: review?(pedemont)

Updated

14 years ago
Attachment #148231 - Flags: review?(pedemont) → review+
(Assignee)

Comment 14

14 years ago
Created attachment 148233 [details] [diff] [review]
leave win as 8U
(Assignee)

Updated

14 years ago
Attachment #148233 - Flags: superreview?(brendan)
Comment on attachment 148233 [details] [diff] [review]
leave win as 8U

At this point, I'd favor explicit common subexpression elimination, using a
PRUint8 alphaTemp or whatever local. sr=brendan@mozilla.org with that change.

/be
Attachment #148233 - Flags: superreview?(brendan) → superreview+
We want this for 1.7, right?

/be
Flags: blocking1.7+
(Assignee)

Comment 17

14 years ago
Created attachment 148238 [details] [diff] [review]
final version
(Assignee)

Comment 18

14 years ago
Checked in on trunk.
(Assignee)

Updated

14 years ago
Attachment #148238 - Flags: approval1.7?

Comment 19

14 years ago
Comment on attachment 148238 [details] [diff] [review]
final version

a=chofmann for 1.7
Attachment #148238 - Flags: approval1.7? → approval1.7+
(Assignee)

Comment 20

14 years ago
Checked in on branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago14 years ago
Resolution: --- → FIXED

Comment 21

14 years ago
because it was checked in on branch
Keywords: fixed1.7

Comment 22

14 years ago
Verified on the branch, Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.8a2) Gecko/20040701. no crashes on the urls cited in the bug (in primary
windows, tabs, from bookmarks, or url series).
Keywords: fixed1.7 → verified1.7
Product: Core → Core Graveyard
Crash Signature: [@ nsImageWin::DrawToImage]
You need to log in before you can comment on or make changes to this bug.