bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Download filename not correct when saving file



Core Graveyard
File Handling
16 years ago
2 years ago


(Reporter: James T Horn, Assigned: Bill Law)



Firefox Tracking Flags

(Not tracked)





16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461; Hotbar 
4.0; .NET CLR 1.0.3705)
BuildID:    CSWB {1.0}

When you select a file to "download", it will download the file, but the file 
name will not be the correct filename, but the temporary filename that is 
created while downloading the file.

Reproducible: Always
Steps to Reproduce:
1. Go to site that will have a link for saving a file
2. select link and tell where the file will be stored
3. After file finishes downloading, you will not find the correct file name, 
but if you do a directory on files recently created, you will find the file 

Comment 1

16 years ago
Is this related to bug 120327 ?

Comment 2

16 years ago
I tried doing the following: http://www.palmgear.com/software/showsoftware.cfm?
sid=42440420020729134156&prodID=4869 selected to save the file and it worked. 
When I tried http://ftp.support.compaq.com/patches/public/Readme/vms/dec-
axpvms-vms73_rms-v0400--4.readme, then select the dec-axpvms-vms73_rms-v0400--
4.pcsi-dcx_axpexe link, select "Save this file to disk" on the Downloading #1 
window, it trys to give it a name dec-axpvms-vms73_rms-v0400--4.pcsi-
dcx_axpexe.exe (which would be an invalid name). I changed it to file-1.exe 
which works (creats file file-1.exe). 
I would guess the problem is mozilla downloads the file to a temporary name 
(IBK5Y74P.EXE), then tries to rename/copy the file (the temporary file is 
created in the default directory) it gets an error and does not create the 
file, but the temporary files are left in the directory.

Comment 3

16 years ago
Sounds like if the rename/copy fails, then there's no error message output.

But I can't get it to fail. The way the file name handling is done on OpenVMS, a
invalid name such as a.b.c is converted to a_b.c automatically. I could download
that exact RMS patch kit using CSWB V1.0 without a problem.

What version of VMS are you running? Are you up to date on CRTL patches? Have
you defined any VMS_ logical names?
QA Contact: sairuh → petersen

Comment 4

15 years ago
Reporter hasn't gotten back with the requested information in over 6 months, so
I'm closing this bug report. 

Reporter, if this is still a problem using Mozilla 1.3, re-open and post the
requested information.
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.