Javascript menu doesn't work in Mozilla browser

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
17 years ago
4 years ago

People

(Reporter: mlamkin, Assigned: doronr)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
This menu code works in both Netscape 4.x and Internet Explorer, we use a
variation of it for our apps.  Opera almost works with it (it's not perfect),
but the Mozilla browser seems to completely ignore it.  You should be able to
bring this page up and menus should appear when you click the areas where it
suggests.

Comment 1

17 years ago
Unfortunately, there is a lot of outdated stuff lurking on the Netscape site. 
Mozilla does not provide backward compatibility for Netscape 4's non-standard 
DHTML features

http://developer.netscape.com/evangelism/docs/articles/updating-dhtml-web-
pages/ may be useful.

See also bug 89383

Comment 2

17 years ago
Marjorie: good catch!

This page on our own site is using old code dating back to 1997 or so.
Specifically, an external JS file called "menu.js"; a key function there
is showMenu(), which has this structure:


                function showMenu( etc.)
                {
                  if (document.layers)
                  {
                    // do a lot of things
                  }
                  else if (document.all)
                  {
                    // do a lot of things
                  }
                }


This function will not cause any errors in Mozilla/N6/N7, but 
it won't actually do ANYTHING, since |document.layers| is only
supported in NN4, and |document.all| is only supported in IE.

Neither of these proprietary DOM extensions are supported in
Mozilla/N6/N7. Reassigning to Tech Evangelism for disposition.
I know this issue has come up before; but I'm not sure of how
we handle this. 

Compare bug 89383, "netscape.com - Dynamic HTML menus does not work".
Also filed against a "smith_menu" page; so perhaps this bug is just
a duplicate of that one, then -
Assignee: rogerl → doron
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → US General
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: pschwartau → zach
Version: other → unspecified

Updated

16 years ago
Keywords: evang500

Comment 3

16 years ago
doron updated some of smith menu, but in general developer.netscape.com is an
archive and is no longer updated. -> wontfix
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.