Browsing this site causes Mozilla to take 100% CPU for long durations

RESOLVED DUPLICATE of bug 126731

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 126731
16 years ago
16 years ago

People

(Reporter: Amit K, Assigned: jst)

Tracking

({perf})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [site uses "DHTML QuickMenu" template from OpenCube], URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529
BuildID:    2002052918

This site causes Mozilla to take 100% CPU for long periods after which the page
eventually loads correctly.

But the loading time is way too much. 

Reproducible: Always
Steps to Reproduce:
1.Goto www.polycom.com
2.Try going to "Company Info -> Job opportunities" in the menu on the top.
3.Keep an eye on the CPU meter and the page load time


Actual Results:  Page loads take a lot of time with nothing possible in the
meanwhile since it takes 100% CPU

Expected Results:  I tried it with IE, which shows 100% CPU for a fraction of
the time that Mozilla does.

Comment 1

16 years ago
Confirmed:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020722

While loading HOMEPAGE (not page specified in report), I dragged the window, 
and remenants are left all over the screen until the page is done loading. Not 
mozilla's fault, but probably indirectly caused by it's huge CPU use.

Comment 2

16 years ago
This site uses the "DHTML QuickMenu" from OpenCube software,
available at http://www.opencube.com.

<script language="JavaScript1.2">

/*-------------------------------------------
Copyright Notice
--------------------------------------------*/

DQM_Notice = "DHTML QuickMenu, Copyright (c) - 2001, OpenCube Inc. - 
                                                     www.opencube.com"

/*-------------------------------------------
Required menu Settings
--------------------------------------------*/

               etc.
               etc.


It seems like all sites using this have performance issues in Mozilla. 
For example, go to the DHTML QuickMenu link at http://www.opencube.com.
We have this on file in bug 126731, which has not been resolved yet.
Reassigning to DOM Level 0 for parity with the existing bug. 
Assignee: rogerl → jst
Component: JavaScript Engine → DOM Level 0
Keywords: perf
QA Contact: pschwartau → desale
Whiteboard: [site uses "DHTML QuickMenu" template from OpenCube]

Comment 3

16 years ago
Resolving as duplicate. Amit, thank you for this report; you will
be cc'ed on bug 126731 so you can follow its progress -

*** This bug has been marked as a duplicate of 126731 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
just a comment: clicking the "Company Info -> Job opportunities" link doesn't do
a thing on a current Linux build - it just removes the black "hover" color
(untill i move the mouse again). Nothing loads.
You need to log in before you can comment on or make changes to this bug.