Closed Bug 1599708 Opened 10 months ago Closed 10 months ago

browser.newtab.privateAllowed and .extensionControlled are cleared when an unrelated add-on is disabled/removed

Categories

(WebExtensions :: General, defect)

defect
Not set
normal

Tracking

(firefox-esr68 wontfix, firefox71 wontfix, firefox72 verified)

VERIFIED FIXED
mozilla72
Tracking Status
firefox-esr68 --- wontfix
firefox71 --- wontfix
firefox72 --- verified

People

(Reporter: robwu, Assigned: mixedpuppy)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

STR:

  1. Install https://addons.mozilla.org/en-US/firefox/addon/new-tab-homepage/
  2. Install https://addons.mozilla.org/en-US/firefox/addon/new-tab-override/ and allow private access in the post-install doorhanger.
  3. Open a new private browsing window. Open a new tab in that private window. You should see the newtab from the add-on at the previous step.
  4. Visit about:addons and disable the first newtab add-on (from step 1).
  5. Open a new private browsing window. Open a new tab in that private window.

Expected:

  • At step 5, the newtab should still be the extension's newtab, like step 3.

Actual:

  • The default newtab page is opened instead.

This is because in the current implementation of the newtab preference, the relevant prefs are unconditionally cleared whenever the internal "extension-setting-changed" event is emitted when there is no reported change: https://searchfox.org/mozilla-central/rev/cce8b90aece0f42e5025e45282de16066eeaa662/browser/components/extensions/parent/ext-url-overrides.js#89-90,120

Reproduced on Firefox 70.0.1 and Firefox Nightly 72.0a1 buildID 20191126212708

Blocks: 1578508
Depends on: 1548700
Assignee: nobody → mixedpuppy
Pushed by scaraveo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3dc2c0a968db
fix setting newtab when setting is updated r=robwu
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72

Hello,

Verified the fix on the latest Nightly (72.0a1/20191128214853) under Windows 10 Pro 64-bit and MacOS Catalina 10.15.

Following the provided STR, upon reaching step 5, the new tab will be the extension controlled new tab as specified in step 3, confirming the fix.

Status: RESOLVED → VERIFIED
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.