All users were logged out of Bugzilla on October 13th, 2018

no Cancel button on Find dialog, even though Esc works

VERIFIED WONTFIX

Status

--
minor
VERIFIED WONTFIX
16 years ago
16 years ago

People

(Reporter: tfo, Assigned: saari)

Tracking

Details

(Reporter)

Description

16 years ago
this is not a big deal, but, as a bug, it's worth mentioning. despite the lack
of a Cancel button on the Edit->Find in Page... dialog, Esc does close the
window. still, it would look better, probably, if the interface button were there.

to reproduce:
1. launch Navigator.
2. visit http://chimera.mozdev.org/
3. hit Cmd-F

no cancel button. but, if you press Esc, the window closes.

Updated

16 years ago
Blocks: 154286

Comment 1

16 years ago
Confirmed using Chimera/20020724. (Note that Mozilla's Find dialog includes a
Cancel button.)
(Assignee)

Comment 2

16 years ago
Isn't the red close bubble good enough since the key stroke works?

Comment 3

16 years ago
None of the Apple-built apps I've checked - including Mail, Project Builder,
AppleWorks, Terminal, and TextEdit - have a Cancel button in their Find dialogs.
Their behavior is, essentially, the same as Chimera. However, both Internet
Explorer 5.2 and Mozilla (as mentioned) have a Cancel button in their Find dialogs.

I'd say we keep it as is, with no Cancel.
(Reporter)

Comment 4

16 years ago
actually, after comparing to other OS X apps, i agree. i'd be fine if this got
filed as WON'T FIX.

Comment 5

16 years ago
wontfix per comment 4
What on earth would it mean to cancel a "find" anyways???
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 6

16 years ago
The window no longer closes when you hit Find either.

Comment 7

16 years ago
Verified 8-10-2002. This actually isn't an issue anymore 'cause Esc doesn't work
anymore.
Status: RESOLVED → VERIFIED

Updated

16 years ago
No longer blocks: 154286
You need to log in before you can comment on or make changes to this bug.