auto-res.net - Site uses outerHTML; and assumes either document.all or document.layers

VERIFIED FIXED

Status

P1
major
VERIFIED FIXED
16 years ago
3 years ago

People

(Reporter: ramon_garcia_f, Unassigned)

Tracking

Details

(Whiteboard: [propietary-js], URL)

(Reporter)

Description

16 years ago
Auto Res is one of the most important bus companies in Spain. It is imposible
to buy a ticket from Mozilla.

To find the blocking page go to the URL above, fill it in. (Note NIF must be
an Spanish valid ID number, and that means that it must be for the form
nnnnnnnnl where n is a number and l is a letter, and the letter is determinated
by a formula. You can use 01234567L as a valid NIF number). Then you arrive to 
a confirmation page. Click next.

"Apellido" means family name.

When you arrive at the page http://www.auto-res.net/Venta/consulta_iber.htm 
"Origen" means "From", "Destino" means "to". After selecting a city in the
"Origen" field, you should see a list of destinations.

The page tries to support Netscape 4.x/Mozilla by using checking 
document.layers and assuming document.all otherwise. However it does not work 
with Netscape 4.x either, since it requires outerHTML.
(Reporter)

Comment 1

16 years ago
You can contact them at auto-res@auto-res.net
nothing more to say -> confirm
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P1
Whiteboard: [propietary-js]
*** Bug 188783 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
Some comments pasted here from bug 188783:

There is a button labeled "Cal" on that page, it does not work either..

The site also fails with Opera and Netscape 4.7.  It is rumoured to fail with IE
on the Mac, somebody may want to check that.

Ruslan Ismailov analyzed the problem and said this:

Tech Evangelism. This dropdown change performed by:

function recargar(){
  if(document.all){
    document.forms[0].target="centro";
    document.forms[0].action='consulta.jsp';
	document.forms[0].submit();
   }else{
  objLayer2.target="centro";  
	objLayer2.action='consulta.jsp';
	objLayer2.submit();
	}
}

It is supported IE and old Netscape stuff.

Comment 5

16 years ago
Easier way to reproduce:

1. Go to the URL
2. Choose the city where you start your trip at the dropdown labeled "Ciudad de   
   Origen:" (city of origin).
3. The dropdown labeled "Ciudad de Destino:" (city of destination) that had
   "Esperando Destino" in it should update with possible destination cities.
4. It does not...
Summary: Site uses outerHTML; and assumes either document.all or document.layers → auto-res.net - Site uses outerHTML; and assumes either document.all or document.layers
-> New component
Component: Europe: West → Spanish

Comment 7

15 years ago
spanish default owner
Assignee: nitot → spanish
QA Contact: brantgurganus2001 → spanish

Comment 8

15 years ago
the original url doesn't exists.
going to the root redirects to http://www.auto-res.net/index.html?a which is a
flash page and it seems to work in Mozilla. (I didn't finished buying ticket)
Resolving as fixed.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 9

14 years ago
I still have some problems with the site, the flash page continuously gives me
session expired errors.  Nevertheless the original problem is gone, so I am
verifying this bug.  The other stuff can go into a new bug.
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.