Closed Bug 1599773 Opened 10 months ago Closed 4 months ago

Implement Page.frameDetached

Categories

(Remote Protocol :: Page, task, P1)

Tracking

(firefox78 fixed)

RESOLVED FIXED
Firefox 78
Tracking Status
firefox78 --- fixed

People

(Reporter: whimboo, Assigned: whimboo)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [puppeteer-beta-mvp])

Attachments

(1 file)

This is the implementation bug for bug 1549513. Moving over the puppeteer-alpha whiteboard entry.

Priority: P2 → P3
Whiteboard: [puppeteer-alpha] → [puppeteer-alpha-reserve]
Depends on: 1565162
Priority: P3 → P2
Whiteboard: [puppeteer-alpha-reserve] → [puppeteer-beta-mvp]
Blocks: 1605359
Assignee: nobody → hskupin
Status: NEW → ASSIGNED
Priority: P2 → P1

After some investigation yesterday we can actually go ahead without the JSWindowActor implemenation (bug 1565162).

No longer depends on: 1565162

The patch here builds on top of bug 1599413.

Depends on: 1599413
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2c3f77cdc4e0
[remote] Implement Page.frameDetached. r=remote-protocol-reviewers,maja_zf
Flags: needinfo?(hskupin)
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/779bc06348ad
[remote] Implement Page.frameDetached. r=remote-protocol-reviewers,maja_zf

Backed out 2 changesets (bug 1599773, bug 1599413) for browser_frameAttached.js failures.

Push with failure: https://treeherder.mozilla.org/#/jobs?repo=autoland&fromchange=800142bdea708f819ee11fadcf08f6cf3170eb32&searchStr=remote&tochange=0f440282ada89ad47b96c81b541e52259bd7eb20&selectedTaskRun=fdhp796-R_iWQlxlyeBWmQ-0

Backout link: https://hg.mozilla.org/integration/autoland/rev/0f440282ada89ad47b96c81b541e52259bd7eb20

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=302874776&repo=autoland&lineNumber=4711

...
[task 2020-05-19T09:23:48.098Z] 09:23:48     INFO - Leaving test bound eventWhenNavigatingWithFrames
[task 2020-05-19T09:23:48.099Z] 09:23:48     INFO - Entering test bound eventWhenNavigatingWithNestedFrames
[task 2020-05-19T09:23:48.099Z] 09:23:48     INFO - CDP server started
[task 2020-05-19T09:23:48.100Z] 09:23:48     INFO - Buffered messages logged at 09:23:47
[task 2020-05-19T09:23:48.100Z] 09:23:48     INFO - CDP client instantiated
[task 2020-05-19T09:23:48.101Z] 09:23:48     INFO - Navigate to a page with nested iframes
[task 2020-05-19T09:23:48.102Z] 09:23:48     INFO - TEST-PASS | remote/test/browser/page/browser_frameAttached.js | Expected amount of frames added - 
[task 2020-05-19T09:23:48.102Z] 09:23:48     INFO - TEST-PASS | remote/test/browser/page/browser_frameAttached.js | Received the expected amount of frameAttached events - 
[task 2020-05-19T09:23:48.103Z] 09:23:48     INFO - TEST-PASS | remote/test/browser/page/browser_frameAttached.js | Found expected frame with id 2147483653 - 
[task 2020-05-19T09:23:48.104Z] 09:23:48     INFO - TEST-PASS | remote/test/browser/page/browser_frameAttached.js | Got expected frame id for frameAttached event - 
[task 2020-05-19T09:23:48.104Z] 09:23:48     INFO - TEST-PASS | remote/test/browser/page/browser_frameAttached.js | Got expected parent frame id for frameAttached event - 
[task 2020-05-19T09:23:48.105Z] 09:23:48     INFO - TEST-PASS | remote/test/browser/page/browser_frameAttached.js | Found expected frame with id 2147483654 - 
[task 2020-05-19T09:23:48.105Z] 09:23:48     INFO - TEST-PASS | remote/test/browser/page/browser_frameAttached.js | Got expected frame id for frameAttached event - 
[task 2020-05-19T09:23:48.106Z] 09:23:48     INFO - TEST-PASS | remote/test/browser/page/browser_frameAttached.js | Got expected parent frame id for frameAttached event - 
[task 2020-05-19T09:23:48.107Z] 09:23:48     INFO - CDP client closed
[task 2020-05-19T09:23:48.108Z] 09:23:48     INFO - CDP server stopped
[task 2020-05-19T09:23:48.108Z] 09:23:48     INFO - Leaving test bound eventWhenNavigatingWithNestedFrames
[task 2020-05-19T09:23:48.109Z] 09:23:48     INFO - Entering test bound eventWhenAttachingFrame
[task 2020-05-19T09:23:48.109Z] 09:23:48     INFO - CDP server started
[task 2020-05-19T09:23:48.110Z] 09:23:48     INFO - CDP client instantiated
[task 2020-05-19T09:23:48.110Z] 09:23:48     INFO - TEST-PASS | remote/test/browser/page/browser_frameAttached.js | Expected amount of frames added - 
[task 2020-05-19T09:23:48.111Z] 09:23:48     INFO - Buffered messages finished
[task 2020-05-19T09:23:48.112Z] 09:23:48     INFO - TEST-UNEXPECTED-FAIL | remote/test/browser/page/browser_frameAttached.js | Received the expected amount of frameAttached events - Got 0, expected 1
[task 2020-05-19T09:23:48.112Z] 09:23:48     INFO - Stack trace:
[task 2020-05-19T09:23:48.112Z] 09:23:48     INFO - chrome://mochikit/content/browser-test.js:test_is:1327
[task 2020-05-19T09:23:48.113Z] 09:23:48     INFO - chrome://mochitests/content/browser/remote/test/browser/page/browser_frameAttached.js:runFrameAttachedTest:107
[task 2020-05-19T09:23:48.113Z] 09:23:48     INFO - chrome://mochitests/content/browser/remote/test/browser/page/browser_frameAttached.js:eventWhenAttachingFrame:76
[task 2020-05-19T09:23:48.113Z] 09:23:48     INFO - chrome://mochitests/content/browser/remote/test/browser/head.js:fn:69
[task 2020-05-19T09:23:48.114Z] 09:23:48     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1064
[task 2020-05-19T09:23:48.114Z] 09:23:48     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1104
[task 2020-05-19T09:23:48.114Z] 09:23:48     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:927
[task 2020-05-19T09:23:48.114Z] 09:23:48     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:918
[task 2020-05-19T09:23:48.114Z] 09:23:48     INFO - GECKO(4280) | 1589880227766	RemoteAgent	TRACE	<-(connection {4c88504c-5e50-4f6f-ae65-c42b306ee92d}) {"method":"Target.targetDestroyed","params":{"targetId":"a7e2e8fd-6524-4a30-9fdf-cbf24dfe397c"}}
[task 2020-05-19T09:23:48.114Z] 09:23:48     INFO - CDP client closed
[task 2020-05-19T09:23:48.115Z] 09:23:48     INFO - GECKO(4280) | 1589880227799	RemoteAgent	TRACE	<-(connection {4c88504c-5e50-4f6f-ae65-c42b306ee92d}) {"method":"Target.targetDestroyed","params":{"targetId":"abca3ca7-0def-4be5-a6ca-adbc9766fde1"}}
[task 2020-05-19T09:23:48.116Z] 09:23:48     INFO - GECKO(4280) | 1589880227799	RemoteAgent	TRACE	<-(connection {4c88504c-5e50-4f6f-ae65-c42b306ee92d}) {"method":"Target.targetDestroyed","params":{"targetId":"456997c5-37c2-42ea-a74d-e837968a6891"}}
[task 2020-05-19T09:23:48.116Z] 09:23:48     INFO - CDP server stopped
[task 2020-05-19T09:23:48.116Z] 09:23:48     INFO - Leaving test bound eventWhenAttachingFrame
[task 2020-05-19T09:23:48.114Z] 09:23:48     INFO - CDP client closed
[task 2020-05-19T09:23:48.115Z] 09:23:48     INFO - GECKO(4280) | 1589880227799	RemoteAgent	TRACE	<-(connection {4c88504c-5e50-4f6f-ae65-c42b306ee92d}) {"method":"Target.targetDestroyed","params":{"targetId":"abca3ca7-0def-4be5-a6ca-adbc9766fde1"}}
[task 2020-05-19T09:23:48.116Z] 09:23:48     INFO - GECKO(4280) | 1589880227799	RemoteAgent	TRACE	<-(connection {4c88504c-5e50-4f6f-ae65-c42b306ee92d}) {"method":"Target.targetDestroyed","params":{"targetId":"456997c5-37c2-42ea-a74d-e837968a6891"}}
[task 2020-05-19T09:23:48.116Z] 09:23:48     INFO - CDP server stopped
[task 2020-05-19T09:23:48.116Z] 09:23:48     INFO - Leaving test bound eventWhenAttachingFrame
[task 2020-05-19T09:23:48.117Z] 09:23:48     INFO - GECKO(4280) | MEMORY STAT | vsize 3234MB | residentFast 409MB | heapAllocated 160MB
[task 2020-05-19T09:23:48.118Z] 09:23:48     INFO - TEST-OK | remote/test/browser/page/browser_frameAttached.js | took 3206ms
Flags: needinfo?(hskupin)

As you can see the problem is not with this patch but with frameAttached which is bug 1599413. Remaining work will happen there.

Flags: needinfo?(hskupin)
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8b594c96ab8e
[remote] Implement Page.frameDetached. r=remote-protocol-reviewers,maja_zf
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 78
Regressions: 1641839
You need to log in before you can comment on or make changes to this bug.