Closed Bug 1599818 Opened 10 months ago Closed 10 months ago

web-platform-test logs frequently too big to parse due to process switch logging

Categories

(Core :: DOM: Content Processes, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox72 --- fixed

People

(Reporter: aryx, Assigned: mattwoodrow)

References

(Regression)

Details

Attachments

(1 file)

Since bug 1584031 landed, some web-platform-test runs have logs above the threshold when they get parsed. wpt can use large urls which are getting logged after [process-switch]: currentRemoteType (webIsolated=http://web-platform.test)

The logs not getting parsed is an issue if there is an actual test failure which won't be exposed in Treeherder due to that.

Example of such a log: https://treeherder.mozilla.org/#/jobs?repo=autoland&group_state=expanded&selectedJob=278357367&resultStatus=testfailed%2Cbusted%2Cexception%2Csuperseded%2Cretry%2Cusercancel&tochange=32e2cc931d79b061d8276fb5bb6617a62510d317&fromchange=7f9d6d996cb78a0303d0bcd0d0fb62cad4299614 (see tab 'Failure Summary' at the bottom).

Flags: needinfo?(matt.woodrow)

It seems that the dump calls in https://phabricator.services.mozilla.com/rMOZILLACENTRAL7a1d401678290ecb56e7a25b6f12371189f0cb76 are to blame.
In browser/base/content/browser.js, toolkit/modules/E10SUtils.jsm and browser/components/sessionstore/SessionStore.jsm

Assignee: nobody → matt.woodrow
Flags: needinfo?(matt.woodrow)
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
You need to log in before you can comment on or make changes to this bug.