Closed Bug 1599935 Opened 3 years ago Closed 3 years ago

"Open With Different Viewer" infobar should be more noticeable

Categories

(Firefox :: PDF Viewer, enhancement)

68 Branch
enhancement
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 73
Tracking Status
firefox-esr68 --- verified
firefox73 --- verified

People

(Reporter: jasonjackson, Assigned: mkaply)

Details

Attachments

(3 files)

Attached image Forms Screen Shot.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

Opened a PDF that contains form fields.

Actual results:

The PDF opened with a grey infobar at the top that says "This PDF document contains forms. The filling of form fields is not supported." and a button "Open With Different Viewer".

Expected results:

A yellow or amber infobar (i.e. warning) should appear so more users will notice it. In our organization, we find more users don't notice it, than those who do.

Component: Untriaged → PDF Viewer
OS: Unspecified → All
Hardware: Unspecified → All
Attached image widevine screenshot.png

This is a good example of an infobar that is noticeable.

This seems like a really good idea. I can do the code, but who would sign off on it?

Status: UNCONFIRMED → NEW
Ever confirmed: true

Note that the PDF Viewer notification bar using PRIORITY_INFO_LOW was a conscious change in bug 894576.

(In reply to Jonas Jenwald [:Snuffleupagus] from comment #3)

Note that the PDF Viewer notification bar using PRIORITY_INFO_LOW was a conscious change in bug 894576.

Interesting. There wasn't a lot of conversation about it back then. Generally anyone opening a fillable form would be very happy to be notified by whatever means necessary that there's actually a way to fill it. It's quite similar to the "Enable DRM" notification so that they can actually play the video. When these things don't work, they switch browsers.

I can only speak for my own organization of 2,500 users that I support. For years, we've receive requests regularly about not being able to fill forms. It's not an exaggeration to say it's the most common Firefox-related issue we receive.

(In reply to Jonas Jenwald [:Snuffleupagus] from comment #3)

Note that the PDF Viewer notification bar using PRIORITY_INFO_LOW was a conscious change in bug 894576.

I just noticed there's no mention of forms or fields in this bug. Was the behaviour with Firefox 22 to display a notification for all PDF files perhaps? I could spin up a VM and install to check...

It looks like the only reason we display warnings now is for unsupported features. So it does seem like yellow makes more sense:

https://searchfox.org/mozilla-central/rev/073b138dcba41cd3f858522e5f0a9ee73e39afa0/browser/extensions/pdfjs/content/PdfStreamConverter.jsm#467

And yes, that old notification displayed for all PDF files. Basically a "this might not work" before we had real PDF support.

Assignee: nobody → mozilla

Stephen,
I think you're the most familiar withe the UX decisions on PDF.js. Do you have any opinion on the color of the fallback bar or know of some who would?

Flags: needinfo?(shorlander)

(In reply to Brendan Dahl [:bdahl] (away until 30th) from comment #8)

Stephen,
I think you're the most familiar withe the UX decisions on PDF.js. Do you have any opinion on the color of the fallback bar or know of some who would?

Yes we try and use the more subtle grey infobar for low impact messages.

I think it makes sense to elevate this to the more obvious warning (yellow) status because of the lack of important functionality.

Flags: needinfo?(shorlander)

bdahl: can you r= https://phabricator.services.mozilla.com/D55527 then?

Thanks!

Flags: needinfo?(bdahl)
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/7d0cec2c6c40
Make unsupported PDF features a warning. r=bdahl
Flags: needinfo?(bdahl)
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 73

Comment on attachment 9112984 [details]
Bug 1599935 - Make unsupported PDF features a warning. r?bdahl

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: PDF viewing (and filling) very common in enterprise, and this is a really nice to have.
  • User impact if declined: Not obvious PDF form won't work in Firefox
  • Fix Landed on Version: 73
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Very low risk, just changes a flag.
  • String or UUID changes made by this patch: None
Attachment #9112984 - Flags: approval-mozilla-esr68?

Adding needinfo on :csasca.
Some existing test cases might need review and update after this change.

To be removed after review and verification.

Flags: qe-verify+
Flags: needinfo?(catalin.sasca)
QA Whiteboard: [qa-triaged]

Verified on 73.0b2, and the yellow banner was present for both widevine and PDF's with forms. Also added a test regarding this scenario.

Will verify it too when it gets to esr.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(catalin.sasca)
Flags: in-testsuite+

Comment on attachment 9112984 [details]
Bug 1599935 - Make unsupported PDF features a warning. r?bdahl

Makes it more obvious when unsupported features are present in a PDF. Approved for 68.5esr.

Attachment #9112984 - Flags: approval-mozilla-esr68? → approval-mozilla-esr68+

Verified on 68.5.0esr (treeherder build) and works as expected.

Flags: in-testsuite+ → in-qa-testsuite+
You need to log in before you can comment on or make changes to this bug.