Closed Bug 1600175 Opened 4 years ago Closed 3 years ago

ubuntu1804 - browser/base/content/test/tabs/browser_multiselect_tabs_drag_to_bookmarks_toolbar.js | Found an unexpected browser window at the end of test run -

Categories

(Firefox :: Tabbed Browser, defect, P5)

defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Blocks 1 open bug)

Details

Filed by: egao [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=278675861&repo=try
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/F7MzfuOOTzWSKwqE8XIzDw/runs/0/artifacts/public/logs/live_backing.log


suite: mochitest-browser-chrome
chunk: 1

context:
[task 2019-11-28T21:15:59.219Z] 21:15:59 INFO - TEST-START | browser/base/content/test/tabs/browser_multiselect_tabs_drag_to_bookmarks_toolbar.js
[task 2019-11-28T21:16:01.702Z] 21:16:01 INFO - GECKO(3047) | MEMORY STAT | vsize 3620MB | residentFast 410MB | heapAllocated 175MB
[task 2019-11-28T21:16:01.702Z] 21:16:01 INFO - TEST-OK | browser/base/content/test/tabs/browser_multiselect_tabs_drag_to_bookmarks_toolbar.js | took 2488ms
[task 2019-11-28T21:16:01.743Z] 21:16:01 INFO - checking window state
[task 2019-11-28T21:16:01.743Z] 21:16:01 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-11-28T21:16:01.743Z] 21:16:01 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/tabs/browser_multiselect_tabs_drag_to_bookmarks_toolbar.js | Found an unexpected browser window at the end of test run -
[task 2019-11-28T21:16:01.743Z] 21:16:01 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-11-28T21:16:01.743Z] 21:16:01 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/tabs/browser_multiselect_tabs_drag_to_bookmarks_toolbar.js | Found an unexpected browser window at the end of test run -
[task 2019-11-28T21:16:01.751Z] 21:16:01 INFO - GECKO(3047) | must wait for focus
[task 2019-11-28T21:16:01.948Z] 21:16:01 INFO - GECKO(3047) | JavaScript error: resource://specialpowers/SpecialPowersParent.jsm, line 580: TypeError: this.manager.rootFrameLoader is null
[task 2019-11-28T21:16:01.950Z] 21:16:01 INFO - GECKO(3047) | JavaScript error: , line 0: NS_ERROR_UNEXPECTED:

:dao - on the new ubuntu1804 test image, I am seeing this test consistently fail. A possibly relevant detail is that ubuntu1804 runs GNOME3 shell, not Unity like ubuntu1604, but other than that all installed dependencies and such are the same as the outgoing ubuntu1604 image.

Could you please redirect the ni to someone who may be able to take a look and comment on the possible cause of failure, thanks!

Flags: needinfo?(dao+bmo)

I was potentially able to fix this issue by installing compiz on the ubuntu1804 docker image and changing how pulseaudio was initialized in the test-linux.sh script. Putting this bug on hold, and if the changes outlined in the previous sentence do not break anything else, I will close this bug as invalid.

This test indeed passed as expected with compiz installed in the test image, but given that compiz is not installed by default on ubuntu1804 and wanting to ensure that we test in the closest possible environment for end users, this bug still needs attention.

Knowing that having only the window manager (which removes the top bar, dock, and other elements of a full desktop environment) should help with the fixing of this test. The expected migration date to ubuntu1804 is end of December.

:Felipe - seeing that Jared is gone on parental leave past the date for expected migration over to ubuntu1804, would you be able to pass on the ni to someone else who may know about this test? I suspect it is the presence of additional UI elements from the full desktop environment which is interfering with the test.

Flags: needinfo?(felipc)

This may be resolved by the changes in Bug 1602701, but if it does not I am proposing to mark this test with a fail-if annotation specific to ubuntu1804.

Flags: needinfo?(jaws)
Flags: needinfo?(felipc)
Flags: needinfo?(dao+bmo)

No recent intermittent failures reported so I'll close this as "works for me".

Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(jaws)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.