Need to be able to configure browser to http-accept: text/html; q=1.0

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
17 years ago
16 years ago

People

(Reporter: karsten, Assigned: darin.moz)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
I keep pages running on an apache 1.3 browser using content negotiation under
the above uri. the problem is, I cannot use this configuration with mozilla 1.0
as browser, as regardless of the language and font choice, the server responds
to requests to e.g. the above uri with a 406 Not Acceptable.

This is due to the fact, that html text is not accepted with full consent, which
looks more politically correct than senseful on today's web.

I had rather have an oppertunity to turn the xml-preference feature off, as
content negotiation is a per-se very nice feature.

Unfortunately, I am not currently in the position to port the above site to
Apache 2.0, and I do not know whether this would change things. I'd anyway be
interested in an answer, if anyone knows.
(Assignee)

Comment 1

17 years ago
what version of apache 1.3 are you using?  a stock apache distribution shouldn't
have any trouble with mozilla's Accept header.
user_pref("network.http.accept.default",
"text/xml,application/xml,application/xhtml+xml,text/html;q=1.0,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,text/css,*/*;q=0.1");

will do what you want.
Yeah, but the mozilla default should be ok.. Can you give a test url which shows
this problem?

Comment 4

16 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/2002090311

This is weird. If I access URL above directly, I get the failure of the original
report. If I use web-sniffer, I get this:
http://webtools.mozilla.org/web-sniffer/view.cgi?url=http%3A%2F%2Fls2-www.cs.uni-dortmund.de%2F%7Etinnefeld%2F&verbose=on

So there is some issue here.

Who is responsible for web-sniffer anyways, there is some suggestion I'd like to
make.

pi
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
(Assignee)

Comment 5

16 years ago
pi: i don't know who "owns" the websniffer these days.  you might want to ask on
#mozilla.

with build 2003022308 under windows, i don't see a 406 response code.  maybe the
site changed?  marking WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 6

16 years ago
yeah, it looks like the server was upgraded to "Apache/2.0.44"

Comment 7

16 years ago
I can confirm that with 1.3b release Linux I don't have a problem with the
original URL. Also the websniffer gives 200.

pi
You need to log in before you can comment on or make changes to this bug.