Closed Bug 1600313 Opened 3 years ago Closed 3 years ago

Drop down menus doesnt work on linux Fedora 31 with dual screen.

Categories

(Core :: Widget: Gtk, defect)

70 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1597990

People

(Reporter: carl.minus, Assigned: jhorak)

References

(Blocks 1 open bug)

Details

(Keywords: multi-monitors)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0

Steps to reproduce:

Open a tab to a page with drop downs, try to change the entry.

Actual results:

Nothing happens, selecting with mouse will not work. One can use <tab> however mouse left click on the drop down fails, with dual screen on linux Fedora 31.

Expected results:

The drop down should display alternatives.

Component: Untriaged → Widget: Gtk
Keywords: multi-monitors
OS: Unspecified → Linux
Product: Firefox → Core
Hardware: Unspecified → x86_64

Wayland issue, please use firefox-x11 package as a workaround for now.
Jan, can you look at it please?
Thanks.

Assignee: nobody → jhorak
Blocks: wayland

I can confirm this issue (wayland only, X11 works fine). Downgrading from 71 -> 70 shows that the bug was introduced in between those two versions.

Testing done on arch linux (kenel 5.3 and 5.4, mesa 19.3-rc5, webrender enabled and disabled, amdgpu and i915 backends both tested)

On Ubuntu Eoan (19.10) with triple-screen, same issue when launched with MOZ_ENABLE_WAYLAND=1
firefox 71.0+build5-0ubuntu0.19.10.1 amd64

Please try the nightly. This issue should be fixed in bug 1597990.

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1597990
You need to log in before you can comment on or make changes to this bug.