Closed Bug 1600450 Opened 4 months ago Closed 4 months ago

Perma xpc Non-local network connections are disabled and a connection attempt to firefox.settings.services.mozilla.com (13.35.125.89) was made - when Gecko 72 merges to Beta on 2019-12-02

Categories

(Firefox :: Remote Settings Client, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 72
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- unaffected
firefox72 + verified

People

(Reporter: CosminS, Unassigned)

References

(Regression)

Details

(Keywords: regression)

[Tracking Requested - why for this release]:

Central as beta simulation:
https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&resultStatus=testfailed%2Cbusted%2Cexception&revision=45db0a68a4e072d658226138e201aa767cd01cba&searchStr=xpc&selectedJob=278877080

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=278878072&repo=try&lineNumber=2695

[task 2019-11-30T12:29:39.469Z] 12:29:39 INFO - TEST-PASS | browser/components/aboutlogins/tests/unit/test_getPotentialBreachesByLoginGUID.js | test_ExceptionsThrownByNonStandardURIsAreCaught - [test_ExceptionsThrownByNonStandardURIsAreCaught : 240] Exceptions thrown by logins with non-standard URIs should be caught. - 1 === 1
[task 2019-11-30T12:29:39.470Z] 12:29:39 INFO - (xpcshell/head.js) | test run_next_test 8 pending (2)
[task 2019-11-30T12:29:39.471Z] 12:29:39 INFO - (xpcshell/head.js) | test test_ExceptionsThrownByNonStandardURIsAreCaught finished (2)
[task 2019-11-30T12:29:39.472Z] 12:29:39 INFO - browser/components/aboutlogins/tests/unit/test_getPotentialBreachesByLoginGUID.js | Starting test_setBreachesFromRemoteSettingsSync
[task 2019-11-30T12:29:39.473Z] 12:29:39 INFO - (xpcshell/head.js) | test test_setBreachesFromRemoteSettingsSync pending (2)
[task 2019-11-30T12:29:39.474Z] 12:29:39 INFO - (xpcshell/head.js) | test run_next_test 8 finished (2)
[task 2019-11-30T12:29:39.474Z] 12:29:39 INFO - PID 14332 | FATAL ERROR: Non-local network connections are disabled and a connection attempt to firefox.settings.services.mozilla.com (13.35.125.89) was made.
[task 2019-11-30T12:29:39.475Z] 12:29:39 INFO - PID 14332 | You should only access hostnames available via the test networking proxy (if running mochitests) or from a test-specific httpd.js server (if running xpcshell tests). Browser services should be disabled or redirected to a local server.
[task 2019-11-30T12:29:39.476Z] 12:29:39 INFO - PID 14332 | Hit MOZ_CRASH(Attempting to connect to non-local address!) at /builds/worker/workspace/build/src/netwerk/base/nsSocketTransport2.cpp:1339
[task 2019-11-30T12:29:54.955Z] 12:29:54 INFO - PID 14332 | #01: mozilla::net::nsSocketTransport::OnSocketEvent(unsigned int, nsresult, nsISupports*) [netwerk/base/nsSocketTransport2.cpp:0]
[task 2019-11-30T12:29:54.955Z] 12:29:54 INFO - PID 14332 | #02: mozilla::net::nsSocketEvent::Run() [netwerk/base/nsSocketTransport2.cpp:94]
[task 2019-11-30T12:29:54.956Z] 12:29:54 INFO - PID 14332 | #03: nsThread::ProcessNextEvent(bool, bool*) [xpcom/threads/nsThread.cpp:1250]
[task 2019-11-30T12:29:54.957Z] 12:29:54 INFO - PID 14332 | #04: NS_ProcessNextEvent(nsIThread*, bool) [xpcom/threads/nsThreadUtils.cpp:486]
[task 2019-11-30T12:29:54.957Z] 12:29:54 INFO - PID 14332 | #05: mozilla::net::nsSocketTransportService::Run() [netwerk/base/nsSocketTransportService2.cpp:1017]
[task 2019-11-30T12:29:54.958Z] 12:29:54 INFO - PID 14332 | #06: non-virtual thunk to mozilla::net::nsSocketTransportService::Run() [netwerk/base/nsSocketTransportService2.cpp:0]
[task 2019-11-30T12:29:54.958Z] 12:29:54 INFO - PID 14332 | #07: nsThread::ProcessNextEvent(bool, bool*) [xpcom/threads/nsThread.cpp:1250]
[task 2019-11-30T12:29:54.959Z] 12:29:54 INFO - PID 14332 | #08: NS_ProcessNextEvent(nsIThread*, bool) [xpcom/threads/nsThreadUtils.cpp:486]
[task 2019-11-30T12:29:54.960Z] 12:29:54 INFO - PID 14332 | #09: mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*) [ipc/glue/MessagePump.cpp:333]
[task 2019-11-30T12:29:54.960Z] 12:29:54 INFO - PID 14332 | #10: MessageLoop::Run() [ipc/chromium/src/base/message_loop.cc:291]
[task 2019-11-30T12:29:54.961Z] 12:29:54 INFO - PID 14332 | #11: nsThread::ThreadFunc(void*) [xpcom/threads/nsThread.cpp:460]
[task 2019-11-30T12:29:55.082Z] 12:29:55 INFO - PID 14332 | #12: _pt_root [nsprpub/pr/src/pthreads/ptthread.c:204]
[task 2019-11-30T12:29:55.083Z] 12:29:55 INFO - PID 14332 | #13: libpthread.so.0 + 0x76ba
[task 2019-11-30T12:29:55.084Z] 12:29:55 INFO - PID 14332 | #14: libc.so.6 + 0x10741d
[task 2019-11-30T12:29:55.085Z] 12:29:55 INFO - PID 14332 | #15: ??? (???:???)
[task 2019-11-30T12:29:55.085Z] 12:29:55 INFO - PID 14332 | ExceptionHandler::GenerateDump cloned child 14356
[task 2019-11-30T12:29:55.086Z] 12:29:55 INFO - PID 14332 | ExceptionHandler::SendContinueSignalToChild sent continue signal to child
[task 2019-11-30T12:29:55.087Z] 12:29:55 INFO - PID 14332 | ExceptionHandler::WaitForContinueSignal waiting for continue signal...
[task 2019-11-30T12:29:55.087Z] 12:29:55 INFO - <<<<<<<
[task 2019-11-30T12:29:55.088Z] 12:29:55 INFO - mozcrash Copy/paste: /builds/worker/workspace/build/linux64-minidump_stackwalk /tmp/xpc-other-8SasAR/62326046-f9ed-0648-73aa-7d09982b135c.dmp /builds/worker/workspace/build/symbols
[task 2019-11-30T12:30:00.385Z] 12:30:00 INFO - mozcrash Saved minidump as /builds/worker/workspace/build/blobber_upload_dir/62326046-f9ed-0648-73aa-7d09982b135c.dmp
[task 2019-11-30T12:30:00.386Z] 12:30:00 INFO - mozcrash Saved app info as /builds/worker/workspace/build/blobber_upload_dir/62326046-f9ed-0648-73aa-7d09982b135c.extra
[task 2019-11-30T12:30:00.387Z] 12:30:00 WARNING - PROCESS-CRASH | browser/components/aboutlogins/tests/unit/test_getPotentialBreachesByLoginGUID.js | application crashed [@ mozilla::net::nsSocketTransport::InitiateSocket()]
[task 2019-11-30T12:30:00.387Z] 12:30:00 INFO - Crash dump filename: /tmp/xpc-other-8SasAR/62326046-f9ed-0648-73aa-7d09982b135c.dmp
[task 2019-11-30T12:30:00.387Z] 12:30:00 INFO - Operating system: Linux
[task 2019-11-30T12:30:00.388Z] 12:30:00 INFO - 0.0.0 Linux 4.4.0-1014-aws #14taskcluster1-Ubuntu SMP Tue Apr 3 10:27:00 UTC 2018 x86_64
[task 2019-11-30T12:30:00.388Z] 12:30:00 INFO - CPU: amd64
[task 2019-11-30T12:30:00.389Z] 12:30:00 INFO - family 6 model 85 stepping 4
[task 2019-11-30T12:30:00.389Z] 12:30:00 INFO - 2 CPUs
[task 2019-11-30T12:30:00.390Z] 12:30:00 INFO - GPU: UNKNOWN
[task 2019-11-30T12:30:00.391Z] 12:30:00 INFO - Crash reason: SIGSEGV /SEGV_MAPERR
[task 2019-11-30T12:30:00.391Z] 12:30:00 INFO - Crash address: 0x0
[task 2019-11-30T12:30:00.392Z] 12:30:00 INFO - Process uptime: not available
[task 2019-11-30T12:30:00.393Z] 12:30:00 INFO - Thread 3 (crashed)
[task 2019-11-30T12:30:00.393Z] 12:30:00 INFO - 0 libxul.so!mozilla::net::nsSocketTransport::InitiateSocket() [nsSocketTransport2.cpp:45db0a68a4e072d658226138e201aa767cd01cba : 1339 + 0x29]

This looks to be a regression from https://hg.mozilla.org/mozilla-central/rev/6e7d21f9e8efc7c6b657b2e28884fc3bb2b9861b. Mathieu, could you please take a look over this?

Flags: needinfo?(mathieu)

This is because Cu.isInAutomation is a lie for xpcshell tests (x-ref https://twitter.com/gijskruitbosch/status/1126449767863726080 ; https://bugzilla.mozilla.org/show_bug.cgi?id=1548941#c11 ). Yes, this is a footgun, but we don't really have time to fix it here.

We can fix this by setting the relevant "allow viruses to take over this computer" pref (cf. https://searchfox.org/mozilla-central/rev/f66eb70d175a2017a74b4f61ed556d5835c8a9db/testing/profiles/common/user.js#55 ).

The question I have is... which xpcshell tests are affected? Just this one? I expect other xpcshell tests that somehow instantiate remote settings may also be affected...

Flags: needinfo?(csabou)

Dozens of tests are affected, see the xpcshell runs for a platform at https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&selectedJob=278883034&resultStatus=testfailed%2Cbusted%2Cexception&revision=45db0a68a4e072d658226138e201aa767cd01cba&searchStr=xpc

Shall bug 1598562 be backed out for now and later uplifted (to 72 beta) if necessary?

Flags: needinfo?(csabou) → needinfo?(gijskruitbosch+bugs)

(In reply to Sebastian Hengst [:aryx] (needinfo on intermittent or backout) from comment #2)

Dozens of tests are affected, see the xpcshell runs for a platform at https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&selectedJob=278883034&resultStatus=testfailed%2Cbusted%2Cexception&revision=45db0a68a4e072d658226138e201aa767cd01cba&searchStr=xpc

Shall bug 1598562 be backed out for now and later uplifted (to 72 beta) if necessary?

I think we're going to have to, yes, because which extensions tests are affected is likely a timing issue, and it'll be anything that starts up enough of the add-on architecture to trip the blocklist starting which will trip remote settings (or anything else tripping remote settings), and changing the return value of Cu.isInAutomation for all those tests is going to influence other things, so I'm not confident that we can fix it without further fallout.

:Aryx, can you do the backout?

Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(aryx.bugmail)
Flags: needinfo?(aryx.bugmail)
Status: NEW → RESOLVED
Closed: 4 months ago
Flags: needinfo?(mathieu)
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72

Verified fixed with yesterday's beta sim and on beta.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.