Closed Bug 1600507 Opened 4 months ago Closed 4 months ago

Deal with null gMsgFolderSelected

Categories

(SeaMonkey :: MailNews: Message Display, defect)

defect
Not set

Tracking

(seamonkey2.49esr unaffected, seamonkey2.53 affected, seamonkey2.57esr fixed)

RESOLVED FIXED
seamonkey 2.70
Tracking Status
seamonkey2.49esr --- unaffected
seamonkey2.53 --- affected
seamonkey2.57esr --- fixed

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

Details

Attachments

(1 file)

Currently get spurious error messages in the console when gMsgFolderSelected is null, need to check if variables exist before trying to use them.

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: spurious error messages
Testing completed (on m-c, etc.): 2.53.1
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: none

Attachment #9112749 - Flags: review?(frgrahl)
Attachment #9112749 - Flags: approval-comm-release?
Attachment #9112749 - Flags: approval-comm-esr60?
Comment on attachment 9112749 [details] [diff] [review]
Check for existance

LGTM
Attachment #9112749 - Flags: review?(frgrahl)
Attachment #9112749 - Flags: review+
Attachment #9112749 - Flags: approval-comm-release?
Attachment #9112749 - Flags: approval-comm-release+
Attachment #9112749 - Flags: approval-comm-esr60?
Attachment #9112749 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/f4555c61a7b9
Deal with null gMsgFolderSelected. r=frg

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.