Closed Bug 1600606 Opened 1 year ago Closed 1 year ago

port changes from "Bug 1493292 - Remove aDataLen parameters from nsITransferable" and bug 1503588 to Thunderbird

Categories

(Thunderbird :: General, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 73.0

People

(Reporter: mkmelin, Assigned: khushil324)

Details

Attachments

(1 file, 1 obsolete file)

nsITransferable doesn't use the length param anymore, we have some left in tb:
https://searchfox.org/comm-central/search?q=getAnyTransferData&path=

Bug 1503588 and Bug 1493292 removed them.
https://hg.mozilla.org/mozilla-central/log/tip/widget/nsITransferable.idl

  • nsITransferable.setTransferData
  • nsITransferable.getTransferData
  • nsITranserfable.getFlavorData
  • nsITransferable.getAnyTransferData
Assignee: nobody → khushil324
Status: NEW → ASSIGNED
Comment on attachment 9113588 [details] [diff] [review]
Bug-1600606_remove-length-nsITransferable-0.patch

Review of attachment 9113588 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thx! r=mkmelin

::: calendar/base/content/calendar-clipboard.js
@@ +114,5 @@
>  
>      // Add data objects to transferable
>      // Both Outlook 2000 client and Lotus Organizer use text/unicode
>      // when pasting iCalendar data.
> +    trans.setTransferData("text/calendar", icsWrapper); // double byte data

you can remove this comment as there's not the *2 anymore
Attachment #9113588 - Flags: review?(mkmelin+mozilla) → review+
Attachment #9113588 - Attachment is obsolete: true
Attachment #9113727 - Flags: review+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/ea36e46709b5
Remove length parameter from nsITransferable methods. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Try to do a push after each M-C merge. You've already missed a merge today. Makes it harder to find the cause of bustages.

Target Milestone: --- → Thunderbird 73.0
You need to log in before you can comment on or make changes to this bug.