Closed Bug 1600680 Opened 4 months ago Closed 4 months ago

Another race condition with autocompletion

Categories

(DevTools :: Console, defect, P2)

defect

Tracking

(firefox73 fixed)

RESOLVED FIXED
Firefox 73
Tracking Status
firefox73 --- fixed

People

(Reporter: julienw, Assigned: nchevobbe)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

I found another occurrence of the problem described and fixed in bug 1595068.

STR:

  1. open the console.
  2. Enter const then press enter super quick.
    => cconsole is written most of the time.

This happened especially to me when I wrote something like:
class bla = new Foo();
And then went to correct class to const, and then pressed enter to run it, just it didn't work because of this issue.

Priority: -- → P2

This ensures the selected item of the autocomplete
popup is updated, so if the user accepts the completion
it will retrieve the right text.

Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Duplicate of this bug: 1488444
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e823e110d07b
Fix race issue in autocompletion + Enter. r=Honza.
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 73
Blocks: 1624661
You need to log in before you can comment on or make changes to this bug.