Closed Bug 1600838 Opened 2 years ago Closed 2 years ago

Make conditioned profiles for desktop Firefox the default in Raptor and Browsertime

Categories

(Testing :: Raptor, task, P1)

Version 3
task

Tracking

(firefox73 fixed)

RESOLVED FIXED
mozilla73
Tracking Status
firefox73 --- fixed

People

(Reporter: stephend, Assigned: stephend)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Let's make conditioned profiles the default for Firefox, for Raptor and Browsertime.

GeckoView-based Android support is still being worked on in bug 1597711, and might still block this bug, partially (depending on how cleanly/permanently we wish to switch conditioned profiles to the default).

This will involve, among other things (which will be filed separately, and set to either blocking this bug or bug 1596491), changes to the following:

taskcluster/ci/test/raptor.yml

taskcluster/taskgraph/transforms/raptor.py

testing/mozharness/mozharness/mozilla/testing/raptor.py

testing/raptor/raptor/cmdline.py

testing/raptor/raptor/raptor.py

testing/raptor/raptor/results.py

Status: NEW → ASSIGNED
Priority: -- → P1

The current patch approach (https://searchfox.org/mozilla-central/rev/8bc24752246aeac8a9aed566cf1caccf88d97d11/taskcluster/taskgraph/transforms/raptor.py#171-199) still breaks an Android 7 power unittest , aarch64, and a unittest for desktop Firefox.

This is because it removes build_condprof_tests (which keyed off of the condprof: True flag, and thus, gracefully-degraded on both platforms, before. Judging by an earlier test push to try, Chrome might be OK?

Latest push to try here with "only a couple" unittests failures I've introduced; will fix next: https://treeherder.mozilla.org/#/jobs?repo=try&tier=1%2C2%2C3&revision=e3d045bd0422fb246a0c1bca73244566cc0ce967

Summary: Make conditioned profiles for Firefox the default, for Raptor and Browsertime → Make conditioned profiles for Firefox the default, for desektop Firefox in Raptor and Browsertime
Summary: Make conditioned profiles for Firefox the default, for desektop Firefox in Raptor and Browsertime → Make conditioned profiles for desktop Firefox the default, in Raptor and Browsertime
Attachment #9113513 - Attachment description: Bug 1600838 - [WIP] Make conditioned profiles for Firefox the default, for Raptor and Browsertime → Bug 1600838 - Make conditioned profiles for desktop Firefox the default, in Raptor and Browsertime. r?tarek, r?#perftest
Attachment #9113513 - Attachment description: Bug 1600838 - Make conditioned profiles for desktop Firefox the default, in Raptor and Browsertime. r?tarek, r?#perftest → Bug 1600838 - Make conditioned profiles for desktop Firefox the default, in Raptor and Browsertime. r?tarek,#perftest

Latest try push -- which incorporates feedback from :sparky (thanks!) -- still has failing unittests, but that's a separate issue, which I hope will be fixed by bug 1601759, so we can land the missing-piece rename in bug 1599471 can successfully use the updated API's ROOT_URL, etc.: from bug 1601197:

https://treeherder.mozilla.org/#/jobs?repo=try&tier=1%2C2%2C3&revision=0005269cab40f5bff0dbe1323a9bd1f9bbfe8ec7

Currently, there is a mismatch in the conditioned-profile's tarball name and location, like so:

Duplicate of this bug: 1601759
Summary: Make conditioned profiles for desktop Firefox the default, in Raptor and Browsertime → Make conditioned profiles for desktop Firefox the default in Raptor and Browsertime
Attachment #9113513 - Attachment description: Bug 1600838 - Make conditioned profiles for desktop Firefox the default, in Raptor and Browsertime. r?tarek,#perftest → Bug 1600838 - Make conditioned profiles for desktop Firefox the default in Raptor and Browsertime. r?tarek,#perftest
Duplicate of this bug: 1599471
Attachment #9113513 - Attachment description: Bug 1600838 - Make conditioned profiles for desktop Firefox the default in Raptor and Browsertime. r?tarek,#perftest → Bug 1600838 - Make conditioned profiles for desktop Firefox the default, in Raptor and Browsertime. r?tarek,#perftest
Pushed by sdonner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/86faf1cf452a
Make conditioned profiles for desktop Firefox the default, in Raptor and Browsertime.  r=tarek,perftest-reviewers,sparky
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
Regressions: 1603990
You need to log in before you can comment on or make changes to this bug.