Flash plugin crashing with Mozilla 1.0 in 8-bit mode

RESOLVED WONTFIX

Status

External Software Affecting Firefox
Flash (Adobe)
--
critical
RESOLVED WONTFIX
16 years ago
2 years ago

People

(Reporter: Alex, Assigned: Jim Dunn)

Tracking

({crash, stackwanted})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: works in 24-bit mode)

(Reporter)

Description

16 years ago
Mozilla Browser shuts down when opening a Shockwave Flash file, using HP
compiled plugin, even though everything works OK with Netscape 4.78.

HP-UX version: 11.00

Mozilla version: Mozilla/5.0 (X11; U; HP-UX 9000/785; en-US; rv:1.0.0)
Gecko/20020605

Plugin version: Shockwave Flash Player 5 (compiled for HPUX 11)


The reported error is:

Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 139 error_code 8 request_code 72 minor_code 0



For getting the plugin see
http://www.hp.com/workstations/support/software/hpux/macromedia/

Comment 1

16 years ago
Can you get a stacktrace from a debug build ?
Severity: major → critical
Keywords: crash, stackwanted
(Reporter)

Comment 2

16 years ago
Please, let me point out that I'm not really into Unix programming
(just some limited knowledge).
Just found the error and wanted to let you know.

Anyways, if you guide me I can grab data for you.

Comment 3

16 years ago
CC'ing jdunn@netscape.com from other bug reports, seemed to have HP-UX access.

Comment 4

16 years ago
handing this over to Jim since this is noted to be found on HP UX. Jim can you
help confirm this?
Assignee: beppe → jdunn
(Assignee)

Comment 5

16 years ago
I can' reproduce this, here are the steps I tried:
1) downloaded mozilla 1.0 : http://www.mozilla.org/releases/stable.html
2) downloaded the flash plugin :
    http://www.hp.com/workstations/support/software/hpux/macromedia/
3) after installing both, I linked the flash plugin to mozilla
    cd mozilla/plugins
    ln -s /opt/flash/plugins/ShockwaveFlash.class .
    ln -s /opt/flash/plugins/libflashplayer.so .
4) went to flash site : mozilla www.macromedia.com

Mozilla/5.0 (X11; U; HP-UX 9000/785; en-US; rv:1.0.0) Gecko/20020605
File name: /opt/flash/plugins/libflashplayer.so  Shockwave Flash 5.0 r86

I was running this on the local machine and display, not remotely.
Q: were you running remotely?

If you run 'xdpyinfo' what are the following values ?
depth of root window: ?
default colormap: ?
default visual id: ?

I am assuming you are using HP's gtk+ 1.2.10...

I am "marking" this as worksforme, just "reopen" this
if you are still having problems and can provide the
answers to the above questions.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

16 years ago
Jim,

Here are the answers you requested:\

I'm running local.

Info from "xpdyinfo"

depth of root window:    8 planes
default colormap:    0x25
default visual id:  0x21

I'm using, as you guessed, gtk+ 1.2.10
Anyways, I'm suspecting a bad GTK installation. I'll give it a new try
re-installing and will get back to you.

Thanks.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Assignee)

Comment 7

16 years ago
Ok, can you also run "xwininfo" and click on the "mozilla" window
and send me the output from that.

8bit - ugh, we don't work well with 8bit, my guess is that this
is the problem, but xwininfo should tell me a bit more
(Reporter)

Comment 8

16 years ago
Here comes the xwininfo:

xwininfo: Window id: 0x7c0004a "Bug 160093 - Flash plugin crashing with Mozilla
1.0 - Mozilla {Build ID: 2002060515}"

  Absolute upper-left X:  81
  Absolute upper-left Y:  27
  Relative upper-left X:  0
  Relative upper-left Y:  0
  Width: 1147
  Height: 873
  Depth: 24
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x7c00002 (installed)
  Bit Gravity State: ForgetGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners:  +81+27  -52+27  -52-124  +81-124
  -geometry 1147x873-46+0


Anyways, remember that Netscape Navigator 4.78 worked OK...
(Assignee)

Comment 9

16 years ago
Is there any chance that you can change the "root" window
to a depth of 24bit (rather than 8) and try that?

With using gtk instead of X, my guess is that we have changed
something in passing info back and forth to the plugin
(maybe we just create some generic window to pass to the plugin
 and then flash uses that to create its window to draw into,
 if we are 24bit but we create an 8bit window (we could use the
 default root window attributes) and then flash creates there
 window off or the 8 instead of using the 24bit window... 
 all speculation.

But it would be nice to know if by changing the root window to 24bit
if you still see the crash (if it does fix the problem, then u can
use that as a workaround till we get a chance to straighten this out)


(Reporter)

Comment 10

16 years ago
Maybe...

All I can say is that the Flash window has 8-bit depth, even though the window
who has called it (Navigator, Mozilla) has 24-bit depth...

Check the info for the flash window:

xwininfo: Window id: 0x780057c (has no name)

  Absolute upper-left X:  411
  Absolute upper-left Y:  273
  Relative upper-left X:  411
  Relative upper-left Y:  273
  Width: 200
  Height: 304
  Depth: 8
  Visual Class: PseudoColor
  Border width: 1
  Class: InputOutput
  Colormap: 0x25 (installed)
  Bit Gravity State: ForgetGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: yes
  Map State: IsViewable
  Override Redirect State: yes
  Corners:  +411+273  -667+273  -667-445  +411-445
  -geometry 200x304+411+273


The Navigator window from where I opened a Flash object has:

xwininfo: Window id: 0x7800463 "Netscape: "

  Absolute upper-left X:  270
  Absolute upper-left Y:  19
  Relative upper-left X:  0
  Relative upper-left Y:  0
  Width: 945
  Height: 695
  Depth: 24
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x7800015 (installed)
  Bit Gravity State: ForgetGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners:  +270+19  -65+19  -65-310  +270-310
  -geometry 945x695-59+-8


I will try the 24-bit root window as soon as I can and let you know. I will take
some time, because some of the applications I use for working (what I'm supposed
to be doing right now) need 8-bit color...
(Reporter)

Comment 11

16 years ago
Check this bug out. It has to do with gtk, windows depth problems and the infamous 
"BadMatch" error 

http://mail.gnome.org/archives/gtk-devel-list/2002-April/msg00073.html

Rings any bell?
(Reporter)

Comment 12

16 years ago
GOOD NEWS
---------

I've tried to switch the Root Window to 24-bit plane and it worked!

So maybe it's related to some parameter passing between plugins and the Mozilla
application, that used to be OK in Navigator (remember that Navigator creates a
8-bit Pseudocolor window for Flas, even though it's own window is 24-bit Truecolor)

Anyway, what a shame my other applications require 8-bit depth. I won't be able
to workaround the problem until we (actually you) fix it.

Thanks. Hope it helped.

Updated

15 years ago
Summary: Flash plugin crashing with Mozilla 1.0 → Flash plugin crashing with Mozilla 1.0 in 8-bit mode
Whiteboard: works in 24-bit mode
(Assignee)

Comment 13

15 years ago
I am marking this wontfix because
A) I am not working on HP-UX that much any more
B) The workaround is to have 24bit visual when you boot
C) Hopefully gtk2 will fix this
D) HP-UX isn't even building these days
E) There is a cross platform bug open somewhere that is this exact bug

If someone wants to reopen this, fine but please assign
it to someone who is working on HP
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → WONTFIX

Updated

8 years ago
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: shrir → adobe-flash
Version: Trunk → 5.x

Comment 14

2 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 5.x → unspecified
You need to log in before you can comment on or make changes to this bug.