Closed Bug 1600955 Opened 3 years ago Closed 2 years ago

Port |Bug 501426 - make the open tabs in background pref be named mail.tabs.loadInBackground and allow overriding default for context/middle click with the shift key| to SeaMonkey

Categories

(SeaMonkey :: MailNews: Message Display, enhancement)

enhancement
Not set
normal

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53 fixed, seamonkey2.57esr fixed)

RESOLVED FIXED
seamonkey 2.71
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 --- fixed
seamonkey2.57esr --- fixed

People

(Reporter: iannbugzilla, Assigned: iannbugzilla)

References

Details

(Whiteboard: SM2.53.2)

Attachments

(1 file)

Port the relevant changes from:

  • Bug 501426 - make the open tabs in background pref be named mail.tabs.loadInBackground and allow overriding default for context/middle click with the shift key
  • Bug 467768 - No way to make mail open in tabs by default
  • Bug 512375 - Make message header "other actions' contain an appropriate default set of actions
Type: task → enhancement
Attached patch Tab mail patchSplinter Review

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: No way to have a separate pref for mail tab behaviour
Testing completed (on m-c, etc.): 2.53.2
Risk to taking this patch (and alternatives if risky): None
String changes made by this patch: Extra strings and help content

Attachment #9118085 - Flags: review?(frgrahl)
Attachment #9118085 - Flags: approval-comm-release?
Attachment #9118085 - Flags: approval-comm-esr60?
Comment on attachment 9118085 [details] [diff] [review]
Tab mail patch

lgtm

I am not sure if we break add-ons with the new open tab function. Worst case we could put a compatibility setting in later like in browser tabmail which checks for some functions if an array/object or separate arguments are passed.
Attachment #9118085 - Flags: review?(frgrahl)
Attachment #9118085 - Flags: review+
Attachment #9118085 - Flags: approval-comm-release?
Attachment #9118085 - Flags: approval-comm-release+
Attachment #9118085 - Flags: approval-comm-esr60?
Attachment #9118085 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/fa0098e6b23f
Port |Bug 501426 - make the open tabs in background pref be named mail.tabs.loadInBackground and allow overriding default for context/middle click with the shift key| to SeaMonkey. r=frg

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey 2.71
You need to log in before you can comment on or make changes to this bug.