Date of email messages is taken from sender's computer instead of receiver's

VERIFIED DUPLICATE of bug 123786

Status

--
enhancement
VERIFIED DUPLICATE of bug 123786
17 years ago
10 years ago

People

(Reporter: markus.baumgartner, Assigned: mscott)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020729
BuildID:    2002072904

The Mozilla mail client displays the date/time of any new email message as the
date/time that was set on the sender's computer. If this date/time is not
accurate, new mail will not show up on top (bottom) of the list of messages,
even if sorted by date.

I do not know if this behaviour is by design or if it is a bug, but I consider
it incorrect behaviour. I suggest that the message date should be defined as the
date the message is fetched from the mail server by the receiver not when it is
has been sent by the sender. At least there should be an option to change this
behaviour into what I suggested.

Reproducible: Always
Steps to Reproduce:
1. Change system clock to any wrong date
2. Send a test mail to your email address
3. Change system clock to the correct date
4. Receive mail


Actual Results:  Mail will not show up on top (bottom) of message list if sorted
by date

Expected Results:  Mail should be on top of list, as the date was correct when
the message was fetched from the server.

Updated

17 years ago
Severity: normal → enhancement
QA Contact: gayatri → laurel
Whiteboard: DUPEME

Comment 1

17 years ago
You know, we do have a sort by Order Received -- it's menu item View|Sort
by|Order Received.
(Reporter)

Comment 2

17 years ago
Ah thanks, I did not know that. That feature is well hidden though and not
quickly accessible if one wants to quickly change sort order by clicking on
column headers.

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 123786 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
marking verified as a duplicate
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.